summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-01-29 10:53:46 -0500
committerBrian Evans <grknight@gentoo.org>2018-01-29 11:44:01 -0500
commit238a1079dbf87e7df2e29283a07866b6409ba1c4 (patch)
tree19962adee63786469d08c0d52a841a91f09b33c7 /dev-php/pecl-raphf
parentnet-p2p/cpuminer-opt: 3.8.0 version bump (diff)
downloadgentoo-238a1079dbf87e7df2e29283a07866b6409ba1c4.tar.gz
gentoo-238a1079dbf87e7df2e29283a07866b6409ba1c4.tar.bz2
gentoo-238a1079dbf87e7df2e29283a07866b6409ba1c4.zip
dev-php/pecl-raphf: Revbumps to use the new PHP_INI_NAME and php 7.2
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'dev-php/pecl-raphf')
-rw-r--r--dev-php/pecl-raphf/pecl-raphf-1.1.2-r2.ebuild42
-rw-r--r--dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild40
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-php/pecl-raphf/pecl-raphf-1.1.2-r2.ebuild b/dev-php/pecl-raphf/pecl-raphf-1.1.2-r2.ebuild
new file mode 100644
index 000000000000..4fedb7a084a9
--- /dev/null
+++ b/dev-php/pecl-raphf/pecl-raphf-1.1.2-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PHP_EXT_NAME="raphf"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_ECONF_ARGS=""
+PHP_INI_NAME="30-${PHP_EXT_NAME}"
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php5-6"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A reusable, persistent handle and resource factory API"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+PDEPEND="
+ php_targets_php7-0? ( dev-php/pecl-raphf:7[php_targets_php7-0] )
+ php_targets_php7-1? ( dev-php/pecl-raphf:7[php_targets_php7-1] )
+ php_targets_php7-2? ( dev-php/pecl-raphf:7[php_targets_php7-2] )"
+
+src_prepare() {
+ if use php_targets_php5-6 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php5-6 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}
diff --git a/dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild b/dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild
new file mode 100644
index 000000000000..51817913cb68
--- /dev/null
+++ b/dev-php/pecl-raphf/pecl-raphf-2.0.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PHP_EXT_NAME="raphf"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_ECONF_ARGS=""
+PHP_INI_NAME="30-${PHP_EXT_NAME}"
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+# Only really build for 7.x
+USE_PHP="php7-0 php7-1 php7-2"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A reusable, persistent handle and resource factory API"
+LICENSE="BSD-2"
+SLOT="7"
+IUSE=""
+
+RDEPEND="php_targets_php5-6? ( ${CATEGORY}/${PN}:0[php_targets_php5-6] )"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2; then
+ php-ext-pecl-r3_src_install
+ fi
+}