summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-18 18:53:20 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-18 18:53:47 +0200
commit3846c8bbfee08808ecc0fc6875e2eaefc6c03e93 (patch)
tree3febd03a0743d63093caa3d819c4593b33f9984c /dev-php/phpspec-prophecy/phpspec-prophecy-1.10.3-r1.ebuild
parentdev-libs/apr: sparc stable wrt bug #725372 (diff)
downloadgentoo-3846c8bbfee08808ecc0fc6875e2eaefc6c03e93.tar.gz
gentoo-3846c8bbfee08808ecc0fc6875e2eaefc6c03e93.tar.bz2
gentoo-3846c8bbfee08808ecc0fc6875e2eaefc6c03e93.zip
dev-php/phpspec-prophecy: fix install location
Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/phpspec-prophecy/phpspec-prophecy-1.10.3-r1.ebuild')
-rw-r--r--dev-php/phpspec-prophecy/phpspec-prophecy-1.10.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/phpspec-prophecy/phpspec-prophecy-1.10.3-r1.ebuild b/dev-php/phpspec-prophecy/phpspec-prophecy-1.10.3-r1.ebuild
new file mode 100644
index 000000000000..3dad3fd76a4c
--- /dev/null
+++ b/dev-php/phpspec-prophecy/phpspec-prophecy-1.10.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN="prophecy"
+MY_VENDOR="phpspec"
+
+DESCRIPTION="Highly opinionated mocking framework"
+HOMEPAGE="https://github.com/phpspec/prophecy"
+SRC_URI="https://github.com/${MY_VENDOR}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/prophecy-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ <dev-php/doctrine-instantiator-2
+ <dev-php/phpdocumentor-reflection-docblock-6
+ <dev-php/sebastian-comparator-4
+ <dev-php/sebastian-recursion-context-4
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/${MY_VENDOR}/Prophecy
+ doins -r src/Prophecy/*
+ newins "${FILESDIR}/autoload-1.10.0.php" autoload.php
+}