summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2024-11-18 14:03:23 +0000
committerSam James <sam@gentoo.org>2024-11-25 00:01:57 +0000
commit6d534e80896149a5f7b1c35f4fed2100ef202d1d (patch)
tree8f31ab24e9363fbc9b9249a795a8863478b455c2 /dev-php
parentdev-php/pecl-event: drop 3.0.8 (diff)
downloadgentoo-6d534e80896149a5f7b1c35f4fed2100ef202d1d.tar.gz
gentoo-6d534e80896149a5f7b1c35f4fed2100ef202d1d.tar.bz2
gentoo-6d534e80896149a5f7b1c35f4fed2100ef202d1d.zip
dev-php/pecl-radius: add php 8.3 support
Bug: https://bugs.gentoo.org/943650 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39358 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r4.ebuild b/dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r4.ebuild
new file mode 100644
index 000000000000..187662b880a8
--- /dev/null
+++ b/dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PHP_EXT_NAME="radius"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php8-2 php8-3"
+PHP_EXT_PECL_FILENAME="${PN/pecl-/}-${PV/_beta/b}.tgz"
+PHP_EXT_S="${WORKDIR}/${PHP_EXT_PECL_FILENAME%.tgz}"
+PHP_EXT_NEEDED_USE="pcntl(-),sockets(-)"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="Provides support for RADIUS authentication (RFC 2865) and accounting (RFC 2866)"
+HOMEPAGE="https://pecl.php.net/package/radius"
+S="${PHP_EXT_S}"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+PATCHES=( "${FILESDIR}/1.4.0-php8.patch" )
+
+src_unpack() {
+ default
+ # Non-portable test
+ rm "${S}/tests/radius_close.phpt" || die
+}