summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2018-09-17 17:17:48 -0400
committerMichael Orlitzky <mjo@gentoo.org>2018-09-17 17:21:10 -0400
commitcb4e94e6fbc8e0781b621ee61c52b192529e7714 (patch)
tree1ec6ae74ca82c1951f8eb26a8540399f2e0d4c0f /dev-php
parentmail-client/thunderbird-52.9.1: ppc64 stable, bug 660342 (diff)
downloadgentoo-cb4e94e6fbc8e0781b621ee61c52b192529e7714.tar.gz
gentoo-cb4e94e6fbc8e0781b621ee61c52b192529e7714.tar.bz2
gentoo-cb4e94e6fbc8e0781b621ee61c52b192529e7714.zip
dev-php/smarty: new version 3.1.33 to fix CVE-2018-13982.
Bug: https://bugs.gentoo.org/666440 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/smarty/Manifest1
-rw-r--r--dev-php/smarty/smarty-3.1.33.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-php/smarty/Manifest b/dev-php/smarty/Manifest
index a9bcfbbc3fe8..1006772fc492 100644
--- a/dev-php/smarty/Manifest
+++ b/dev-php/smarty/Manifest
@@ -2,3 +2,4 @@ DIST manual-en.3.1.14.zip 408414 BLAKE2B 03d4e7a386eb3bd5b19e5c555ec34b86812838a
DIST smarty-3.1.30.tar.gz 255464 BLAKE2B 8378e6336f271e3c41e16b8fbb70356827ff4a9a61e3cf2a23fdbd0617155ec9dca6a5b6372327d4b35a5c6f7c3b58e807afe7403b7ed929ebacfb3c36e124d0 SHA512 6ad9a6cf10b81fecbdc4daa4acbd9724db5f1c2a014e35039b36b0bf00ba000946a2126f7da5899e587a79419f451aafcd1ee14597a32cf290bbd0bf13a877d0
DIST smarty-3.1.31.tar.gz 244196 BLAKE2B 695bd40d337e8f2d4a44a7b30b743ab4e5b6a7b024a514de956cd513dd6639ac6f9ae464f0d3b4cfcaf7de17994837a866cdd4945780bd3a96ff32df300302a3 SHA512 807343e4229413ea0f5219a828d4e91603fb5454f4abe8aa2d41f0a6fe32fa476e791340e1e95178ded3774d1524e98489c104c6fa391e70a8225de28fdcca18
DIST smarty-3.1.32.tar.gz 250680 BLAKE2B 92d4942f2d3d802b18082f5f6079c8b6945abadd8ef2c87ea217b106eeeedfbde7f1bd00c6fced67b73fc3cf328ec91fc1fb61c7f991b992167fa9d2fb1f2ad2 SHA512 07c95177172718158b9b562c6d8ff79566f4bd8e07ba394cc82c52dec7ec869935fd03ce523115c08472159adf68b902d1db5f8543201a35adf22027c5978080
+DIST smarty-3.1.33.tar.gz 249999 BLAKE2B 1e174b190238c8b20d5dae9c0c9fdf264c4716ba850599a2a028fe6c307eb3d9d2611e3b928efb9471e051496e4e31502458cd7a71a9318e012d5af7eca2c50e SHA512 443473cf12c7e053744daef7a70d4172979d760278aa1593216d0b70f0c12ca2b48eb79486a1c10a1cf2264da671804b94ee9d538b9013ff0bdc42e28639ca5d
diff --git a/dev-php/smarty/smarty-3.1.33.ebuild b/dev-php/smarty/smarty-3.1.33.ebuild
new file mode 100644
index 000000000000..930a87c95ae0
--- /dev/null
+++ b/dev-php/smarty/smarty-3.1.33.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DOC_PV="3.1.14"
+
+DESCRIPTION="A template engine for PHP"
+HOMEPAGE="https://www.smarty.net/"
+SRC_URI="https://github.com/smarty-php/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( https://www.smarty.net/files/docs/manual-en.${DOC_PV}.zip )"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+BDEPEND="doc? ( app-arch/unzip )"
+
+# PHP unicode support is detected at runtime, and the cached templates
+# that smarty generates depend on it. If, later on, PHP is reinstalled
+# without unicode support, all of the previously-generated cached
+# templates will begin to throw 500 errrors for missing mb_foo
+# functions. See bug #532618.
+RDEPEND="dev-lang/php:*[unicode]"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r libs/*
+
+ local DOCS=( *.txt README README.md )
+ local HTML_DOCS
+ use doc && HTML_DOCS="${WORKDIR}/manual-en/"*
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog
+ elog 'To use it in your scripts, include the Smarty.class.php file'
+ elog "from the \"${PN}\" directory; for example,"
+ elog
+ elog " require('${PN}/Smarty.class.php');"
+ elog
+ elog 'After that, the Smarty class will be available to you.'
+}