summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-28 09:24:23 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-28 10:03:40 +0100
commit874287e2adf9f8999c23121419925ae9700e5b85 (patch)
treefbea26bd228efeb48e97ce5a339d7d23e118be74 /dev-python/Faker
parentdev-python/Faker: Remove old (diff)
downloadgentoo-874287e2adf9f8999c23121419925ae9700e5b85.tar.gz
gentoo-874287e2adf9f8999c23121419925ae9700e5b85.tar.bz2
gentoo-874287e2adf9f8999c23121419925ae9700e5b85.zip
dev-python/Faker: Bump to 11.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Faker')
-rw-r--r--dev-python/Faker/Faker-11.0.0.ebuild29
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-11.0.0.ebuild b/dev-python/Faker/Faker-11.0.0.ebuild
new file mode 100644
index 000000000000..12e618b6e887
--- /dev/null
+++ b/dev-python/Faker/Faker-11.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="https://github.com/joke2k/faker"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/text-unidecode-1.3[${PYTHON_USEDEP}]
+ !dev-ruby/faker"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index b6ec61454e39..4cbd7db26c68 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1 +1,2 @@
DIST Faker-10.0.0.tar.gz 1198872 BLAKE2B 60e4f34a597ca11b0699c330f6cdb0f7f387bb6c54d769513f8e091d00242c7ba4e62fa6b3411ad313a4713e9311b729fb6068acfc4a02b66f07c66656677f33 SHA512 0c22b18d16815ee37d2ea79b4142100479c7b9b9f169817dc9e0fe39495f0646e8d61d704ddba7d36eefb6cb3fb744d179a57216abb15c15ee357c8b12b8b5a4
+DIST Faker-11.0.0.tar.gz 1199121 BLAKE2B e5c4e17daa969249dbf1ae69630a79c50e6e51d63db9997872bd22a7e91db1771fdef984ec5912d42815632598339062be20005e4921c846abf3013e6efc8c89 SHA512 687f47ba613bd2117c412da54e293281bf1943eccde8165cc749be5d176a025d250c831d55a509a6923b3542dba4fe5abce23bd80b980bdca742ecaa837d4334