summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-22 12:25:32 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-22 12:29:04 +0200
commitdf3a453ace97d9e02211ad1add167b6219049ddb (patch)
treeef0bebffa3cdc4f4937a5e1f358052dad746ad36 /dev-python/MechanicalSoup
parentdev-python/marshmallow: Bump to 3.18.0 (diff)
downloadgentoo-df3a453ace97d9e02211ad1add167b6219049ddb.tar.gz
gentoo-df3a453ace97d9e02211ad1add167b6219049ddb.tar.bz2
gentoo-df3a453ace97d9e02211ad1add167b6219049ddb.zip
dev-python/MechanicalSoup: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/MechanicalSoup')
-rw-r--r--dev-python/MechanicalSoup/Manifest1
-rw-r--r--dev-python/MechanicalSoup/MechanicalSoup-1.2.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/MechanicalSoup/Manifest b/dev-python/MechanicalSoup/Manifest
index 32f0e612a905..d4203bb62d6a 100644
--- a/dev-python/MechanicalSoup/Manifest
+++ b/dev-python/MechanicalSoup/Manifest
@@ -1 +1,2 @@
DIST MechanicalSoup-1.1.0.tar.gz 49270 BLAKE2B 947b35d819dc69508595adcfe5a0c8e6bd34888c995e9c3931613498ee1ca840ce16a14359aacbf9d40aa4f9ae59d45d14da5a150e3ce39ae7e72f587c94820e SHA512 26eaa54bcd1c0aac26504d7c482ed001830a1c79bf48a3055cef92348e9336887bef86cda68281911032159a3404a1f4ee8de9b6516d7d767cfd6b3b380c4ebe
+DIST MechanicalSoup-1.2.0.tar.gz 49669 BLAKE2B a9791fd2d389c8a553ed0acce179094770651553b7aaf299ec6779509b4ffb1bb97a4a4afe01af3e4ccb56cf100b5bacc39e9aedf1143a9eb6f4b98dbb020062 SHA512 5857274e07c678dc0e19ad4fef828ccf41bb846edad566c2da9914144ced8802efd546265efac792acbb885b29cab5cde4ac3cd2002826a8bb31f91004eb2caa
diff --git a/dev-python/MechanicalSoup/MechanicalSoup-1.2.0.ebuild b/dev-python/MechanicalSoup/MechanicalSoup-1.2.0.ebuild
new file mode 100644
index 000000000000..c44576b3c1e6
--- /dev/null
+++ b/dev-python/MechanicalSoup/MechanicalSoup-1.2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library for automating interaction with websites"
+HOMEPAGE="
+ https://github.com/MechanicalSoup/MechanicalSoup/
+ https://pypi.org/project/MechanicalSoup/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/beautifulsoup4-4.7[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/requests-mock-1.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_prepare_all() {
+ # Override pytest options to skip coverage and flake8
+ sed -e '/^addopts =/d' -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}