summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <mthode@mthode.org>2015-08-27 16:20:34 -0500
committerMatthew Thode <mthode@mthode.org>2015-08-27 16:22:01 -0500
commit56240c05e5e9fcbeabef53b465f01dadda09b4bb (patch)
tree200bdf9eccfefcdc558ca0af4cf2bf14f850fdf1 /dev-python/PyECLib
parentdev-lisp/sbcl: bump to version 1.2.14 (diff)
downloadgentoo-56240c05e5e9fcbeabef53b465f01dadda09b4bb.tar.gz
gentoo-56240c05e5e9fcbeabef53b465f01dadda09b4bb.tar.bz2
gentoo-56240c05e5e9fcbeabef53b465f01dadda09b4bb.zip
herd/openstack: Split out libs from dev-python/PyECLib
gentoo-bug: 558884 gentoo-bug: 558886
Diffstat (limited to 'dev-python/PyECLib')
-rw-r--r--dev-python/PyECLib/PyECLib-1.0.7-r1.ebuild33
-rw-r--r--dev-python/PyECLib/PyECLib-1.0.7-r2.ebuild27
-rw-r--r--dev-python/PyECLib/files/PyECLib-usr-local2.patch51
3 files changed, 78 insertions, 33 deletions
diff --git a/dev-python/PyECLib/PyECLib-1.0.7-r1.ebuild b/dev-python/PyECLib/PyECLib-1.0.7-r1.ebuild
deleted file mode 100644
index 46a3b946ae75..000000000000
--- a/dev-python/PyECLib/PyECLib-1.0.7-r1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Messaging API for RPC and notifications over a number of different messaging transports"
-HOMEPAGE="https://pypi.python.org/pypi/PyECLib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="dev-libs/liberasurecode"
-
-PATCHES=(
- "${FILESDIR}/1.0.7-erasurecode_locations.patch"
- "${FILESDIR}/PyECLib-usr-local.patch"
-)
-
-python_install() {
- distutils-r1_python_install
- # sed -i "s/^libdir.*$/libdir='\/usr\/lib'/g" "${D}"/usr/lib/libgf_complete.la || die
- # sed -i "s/^dependency_libs.*$/dependency_libs=''/g" "${D}"/usr/lib/libgf_complete.la "${D}"/usr/lib/libJerasure.la || die
- # package installs broken la files...
- rm "${D}"/usr/lib/*.la || die
-}
diff --git a/dev-python/PyECLib/PyECLib-1.0.7-r2.ebuild b/dev-python/PyECLib/PyECLib-1.0.7-r2.ebuild
new file mode 100644
index 000000000000..12215bf8e618
--- /dev/null
+++ b/dev-python/PyECLib/PyECLib-1.0.7-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils multilib
+
+DESCRIPTION="Messaging API for RPC and notifications over a number of different messaging transports"
+HOMEPAGE="https://pypi.python.org/pypi/PyECLib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-libs/jerasure"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="dev-libs/liberasurecode
+ ${CDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/PyECLib-usr-local2.patch"
+)
diff --git a/dev-python/PyECLib/files/PyECLib-usr-local2.patch b/dev-python/PyECLib/files/PyECLib-usr-local2.patch
new file mode 100644
index 000000000000..c0b23d477416
--- /dev/null
+++ b/dev-python/PyECLib/files/PyECLib-usr-local2.patch
@@ -0,0 +1,51 @@
+--- setup.py 2015-08-27 14:33:44.643517647 -0500
++++ setup.py.new 2015-08-27 14:34:05.202517349 -0500
+@@ -60,13 +60,12 @@
+
+ default_library_paths = [default_python_libdir,
+ ('%s/usr/local/lib' % _exec_prefix),
+- '/lib', '/usr/lib', '/usr/local/lib',
+- 'src/c/liberasurecode-1.0.7/src/.libs']
++ '/lib', '/usr/lib', '/usr/local/lib']
+
+ default_include_paths = [default_python_incdir,
+ '/usr/local/include', '/usr/local/include/jerasure',
+ '/usr/include', 'src/c/pyeclib_c',
+- '/usr/local/include']
++ '/usr/include/liberasurecode', '/usr/local/include']
+
+ libflags = ''
+ includeflags = ''
+@@ -120,6 +119,7 @@
+ if (os.path.isfile(library_file_path)):
+ missing = False
+ break
++ missing = False
+ if missing:
+ # try using an integrated copy of the library
+ srcpath = "src/c/"
+@@ -228,24 +228,6 @@
+ ldpath_str = "DYLD_LIBRARY_PATH"
+ else:
+ ldpath_str = "LD_LIBRARY_PATH"
+- print("***************************************************")
+- print("** ")
+- print("** PyECLib libraries have been installed to: ")
+- print("** %susr/local/lib" % installroot)
+- print("** ")
+- print("** Any user using this library must update: ")
+- print("** %s" % ldpath_str)
+- print("** ")
+- print("** Run 'ldconfig' or place this line: ")
+- print("** export %s=%s" % (ldpath_str, "%susr/local/lib"
+- % installroot))
+- print("** ")
+- print("** into .bashrc, .profile, or the appropriate shell")
+- print("** start-up script! Also look at ldconfig(8) man ")
+- print("** page for a more static LD configuration ")
+- print("** ")
+- print("***************************************************")
+-
+
+ module = Extension('pyeclib_c',
+ define_macros=[('MAJOR VERSION', '0'),