summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-01-28 08:40:54 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-01-28 10:54:38 -0500
commit264719821a5bd4811515158139c00fab49689c53 (patch)
tree92884c24e05936b7e789a7c92543acb7d291dde6 /dev-python/PyQt6-WebEngine
parentdev-python/PyQt6: add 6.4.1 (diff)
downloadgentoo-264719821a5bd4811515158139c00fab49689c53.tar.gz
gentoo-264719821a5bd4811515158139c00fab49689c53.tar.bz2
gentoo-264719821a5bd4811515158139c00fab49689c53.zip
dev-python/PyQt6-WebEngine: sync ebuild with PyQt6
No 6.4.1 release (yet) to match PyQt6, so adjusting on its own. Can skip revbump for QT_PV change as 6.3 was ok too, but to avoid the need to track usage of new Qt features will limit to major.minor Qt from now. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/PyQt6-WebEngine')
-rw-r--r--dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.4.0.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.4.0.ebuild b/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.4.0.ebuild
index 38114d7e72a3..8abd9c96b89b 100644
--- a/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.4.0.ebuild
+++ b/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.4.0.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_USE_PEP517=sip
PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 flag-o-matic multiprocessing qmake-utils
-QT_PV="6.3:6" # minimum tested qt version
+QT_PV="$(ver_cut 1-2):6"
MY_P="${P/-/_}"
DESCRIPTION="Python bindings for QtWebEngine"
@@ -35,22 +35,19 @@ BDEPEND="
src_prepare() {
default
- # hack: qmake wants g++ (not clang), try to respect ${CHOST} #726112
+ # hack: qmake queries g++ directly for info (not building) and that doesn't
+ # work with clang, this is to make it at least respect CHOST (bug #726112)
mkdir "${T}"/cxx || die
ln -s "$(type -P ${CHOST}-g++ || type -P g++ || die)" "${T}"/cxx/g++ || die
PATH=${T}/cxx:${PATH}
}
src_configure() {
- append-cxxflags -std=c++17 # for clang and old gcc that default to <17
-
- # workaround until bug 863395 has something to offer
- local qmake6=$(qt5_get_bindir)/qmake
- qmake6=${qmake6//qt5/qt6}
+ append-cxxflags -std=c++17 # for old gcc / clang that use <17 (bug #892331)
DISTUTILS_ARGS=(
--jobs=$(makeopts_jobs)
- --qmake="${qmake6}"
+ --qmake="$(type -P qmake6 || die)"
--qmake-setting="$(qt5_get_qmake_args)"
--verbose