summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-08-28 13:50:38 -0700
committerZac Medico <zmedico@gentoo.org>2019-08-28 13:51:16 -0700
commitba7027eabcb38e2f08fce3aca6511e4e518dfafb (patch)
tree8b8ed8cc991297702db42d75d66cce87975ff2b7 /dev-python/aiohttp/aiohttp-2.3.2.ebuild
parentnet-wireless/iwd: bump to 0.20 (diff)
downloadgentoo-ba7027eabcb38e2f08fce3aca6511e4e518dfafb.tar.gz
gentoo-ba7027eabcb38e2f08fce3aca6511e4e518dfafb.tar.bz2
gentoo-ba7027eabcb38e2f08fce3aca6511e4e518dfafb.zip
dev-python/aiohttp: Remove old versions
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/aiohttp/aiohttp-2.3.2.ebuild')
-rw-r--r--dev-python/aiohttp/aiohttp-2.3.2.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/aiohttp/aiohttp-2.3.2.ebuild b/dev-python/aiohttp/aiohttp-2.3.2.ebuild
deleted file mode 100644
index 54ad3a922519..000000000000
--- a/dev-python/aiohttp/aiohttp-2.3.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_{5,6} )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="http client/server for asyncio"
-HOMEPAGE="https://pypi.org/project/aiohttp/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
-EGIT_REPO_URI="https://github.com/aio-libs/aiohttp"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-CDEPEND="
- >=dev-python/async_timeout-1.2.0[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- >=dev-python/multidict-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/yarl-0.11[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- doc? (
- >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-asyncio[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- ${CDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- www-servers/gunicorn[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}"
-
-DOCS=( CHANGES.rst CONTRIBUTING.rst CONTRIBUTORS.txt HISTORY.rst README.rst )
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- PYTHONPATH="${PWD}:${PYTHONPATH}" ${PYTHON} -m pytest tests/ || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}