summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-16 14:08:12 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-16 14:17:13 +0100
commitf3726e6f42e2e963fda8663ed8a359c54bc1027e (patch)
treeec9e634f9f83e8f65f5bed8f832df0d0777f645e /dev-python/apipkg/files
parentdev-python/argcomplete: Fix remaining MissingTestRestrict (diff)
downloadgentoo-f3726e6f42e2e963fda8663ed8a359c54bc1027e.tar.gz
gentoo-f3726e6f42e2e963fda8663ed8a359c54bc1027e.tar.bz2
gentoo-f3726e6f42e2e963fda8663ed8a359c54bc1027e.zip
dev-python/apipkg: Bump to 1.5, fix tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apipkg/files')
-rw-r--r--dev-python/apipkg/files/apipkg-1.5-pytest-4.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/apipkg/files/apipkg-1.5-pytest-4.patch b/dev-python/apipkg/files/apipkg-1.5-pytest-4.patch
new file mode 100644
index 000000000000..0053e7078e2b
--- /dev/null
+++ b/dev-python/apipkg/files/apipkg-1.5-pytest-4.patch
@@ -0,0 +1,25 @@
+From 81dc0f46754afd44358b8c97ea832030436ac7cb Mon Sep 17 00:00:00 2001
+From: Andy Postnikov <apostnikov@gmail.com>
+Date: Sun, 27 Jan 2019 03:27:18 +0200
+Subject: [PATCH] testing/py-apipkg: fix tests
+
+https://github.com/pytest-dev/apipkg/issues/14
+---
+ testing/py-apipkg/14.patch | 11 +++++++++++
+ testing/py-apipkg/APKBUILD | 7 ++++---
+ 2 files changed, 15 insertions(+), 3 deletions(-)
+ create mode 100644 testing/py-apipkg/14.patch
+
+[inner patch extracted for Gentoo use]
+
+--- a/test_apipkg.py
++++ b/test_apipkg.py
+@@ -13,7 +13,7 @@
+ class TestRealModule:
+
+ def setup_class(cls):
+- cls.tmpdir = py.test.ensuretemp('test_apipkg')
++ cls.tmpdir = py.path.local('test_apipkg')
+ sys.path = [str(cls.tmpdir)] + sys.path
+ pkgdir = cls.tmpdir.ensure('realtest', dir=1)
+