summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-01 19:35:07 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-01 19:37:24 +0200
commita88c4b45eb371d0f75a430da7e0c97ff820a94fe (patch)
treecbe23540a47da227c1c95c7030e0984582477987 /dev-python/apsw
parentdev-util/stripe-mock: Remove old (diff)
downloadgentoo-a88c4b45eb371d0f75a430da7e0c97ff820a94fe.tar.gz
gentoo-a88c4b45eb371d0f75a430da7e0c97ff820a94fe.tar.bz2
gentoo-a88c4b45eb371d0f75a430da7e0c97ff820a94fe.zip
dev-python/apsw: Bump to 3.46.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/Manifest1
-rw-r--r--dev-python/apsw/apsw-3.46.0.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index 6cbc5354ccb5..477197939959 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1 +1,2 @@
DIST apsw-3.45.3.0.gh.tar.gz 904570 BLAKE2B 644c884b6f5624c2d8b48f204a43bbb6dd8761979099e1ebad96a30acc7d79f80549e50300279b8d1061f86f8852735fa92c99df4a6c81a364391a3635464ff1 SHA512 73c09aba4ff211e98dfb3365e5f0202f85fa0a05e78f6a35fe08515e84b74ed1576e7bb5c46c77c309ba3e6acacc5681d31e5a4d3d66835d347d82af8feced74
+DIST apsw-3.46.0.0.gh.tar.gz 905622 BLAKE2B 364d3dd3a967d540f2db15fac60bb082f2bdc4fd012697be2b5b9a1cdba26f0a42697577369bf38a7e022e4c996e5b74cefcaa775618e54834e2cc4fc536e39d SHA512 cfa78dee273e64644e4ce9f0ec158342ed8fb2096e7ae7b8a28aa67016376d3f457ebcd5e612ced544d93980fc918de684e2eae3e570de082b7e613577fd021f
diff --git a/dev-python/apsw/apsw-3.46.0.0.ebuild b/dev-python/apsw/apsw-3.46.0.0.ebuild
new file mode 100644
index 000000000000..7b49484a85a9
--- /dev/null
+++ b/dev-python/apsw/apsw-3.46.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%.*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ enable=load_extension
+ use_system_sqlite_config=True
+ EOF
+}
+
+python_test() {
+ esetup.py build_test_extension
+ cd "${T}" || die
+ "${EPYTHON}" -m apsw.tests -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}