summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-30 20:23:41 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-30 20:38:01 +0100
commitf4ac453bf7ed13de81787a9c5dd60e30cdb29964 (patch)
treedbbdcef3de4ab1b717fdb49138221cb978ae582b /dev-python/apsw
parentapp-emacs/emms: bump to 21 (diff)
downloadgentoo-f4ac453bf7ed13de81787a9c5dd60e30cdb29964.tar.gz
gentoo-f4ac453bf7ed13de81787a9c5dd60e30cdb29964.tar.bz2
gentoo-f4ac453bf7ed13de81787a9c5dd60e30cdb29964.zip
dev-python/apsw: Bump to 3.47.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/Manifest1
-rw-r--r--dev-python/apsw/apsw-3.47.2.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index e243b3a49208..ea2de4a0fa92 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1,3 +1,4 @@
DIST apsw-3.46.1.0.gh.tar.gz 913223 BLAKE2B c0ad61e61a97471ef677ffe80f3f91e6520c95f8cece225a8086884f34de497714892e4ce0ca375f2ec66f48b8ecb4d38dd5ebdb57cd94050ef5eaee20d5d3ee SHA512 3cd81ceab03dadf10d9c10d645d33b962ba9ec55075bb193eb076f458dde11d5c5c6ec087ec31fc96d011ca1b339a9ffe07cb5d660b8205f6f156baaa0b18c81
DIST apsw-3.47.0.0.gh.tar.gz 1633544 BLAKE2B a84634948c760cc8e8d6be83b1667ff86c973a1e8c52172d5f91852d42fd25189b367357f0eb0cb3b7b3868b21553e5258427da0958b5c117e05e55c3496a2b6 SHA512 4b90c7f13dbed9015ce1b7215c9dd6d8889433917e123bfac642f271dfec1d8be929b41fa530e867ec4f068a8c4fc337a82043811e8afcb707b187a46db7e176
DIST apsw-3.47.1.0.gh.tar.gz 1647701 BLAKE2B b40fe83b86ce618234876eb5fad4ae7558d9d360913b7eada60e7ddb2057882cca1c491d8f5893727186b9efe27217f160d0ddf49cda7e547f223fbe63092720 SHA512 520434f89cf3ea317ed2cb9d1746f358d9da4cf136ffe3c8fbf19e27698f8a01ad3d56a90c758c5d7d77e7662fe44898d63f6b2f1c438861054d141dff12128f
+DIST apsw-3.47.2.0.zip 2428145 BLAKE2B 12ece7d7854a729510b2e18d3285fc49135b3cbb3480567a0c6879c98d48b2d49bc75f4cb46af738c4a565cc6c29f7cd5d35fd2c6ea5fe1814e8048030f966fb SHA512 9884f36811bfff7276642841ebaa198669c48f4d54bb764a985ea5bdd88f9f630f9fd8a13cf0a44b5675e374c2a911fcec579ca4165622e8049bff327ef66c1d
diff --git a/dev-python/apsw/apsw-3.47.2.0.ebuild b/dev-python/apsw/apsw-3.47.2.0.ebuild
new file mode 100644
index 000000000000..0feaa2defca6
--- /dev/null
+++ b/dev-python/apsw/apsw-3.47.2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/releases/download/${PV}/${P}.zip
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%.*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+src_configure() {
+ cat >> setup.apsw <<-EOF || die
+ [build_ext]
+ use_system_sqlite_config=True
+ EOF
+}
+
+python_test() {
+ esetup.py build_test_extension
+ cd "${T}" || die
+ "${EPYTHON}" -m apsw.tests -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}