summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Seifert <m.seifert@digitalernachschub.de>2021-11-30 11:53:51 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-09 16:43:17 +0100
commit730657b1064369c2f52011740f9be3d47f96dbc6 (patch)
treecfcd68adfe771889b82544de16cc657b8784db8f /dev-python/argon2-cffi-bindings/argon2-cffi-bindings-21.2.0.ebuild
parentwww-apache/mod_h2: 2.0.2 version bump (diff)
downloadgentoo-730657b1064369c2f52011740f9be3d47f96dbc6.tar.gz
gentoo-730657b1064369c2f52011740f9be3d47f96dbc6.tar.bz2
gentoo-730657b1064369c2f52011740f9be3d47f96dbc6.zip
dev-python/argon2-cffi-bindings: Added v21.2.0
Closes: https://bugs.gentoo.org/827890 Signed-off-by: Michael Seifert <m.seifert@digitalernachschub.de> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argon2-cffi-bindings/argon2-cffi-bindings-21.2.0.ebuild')
-rw-r--r--dev-python/argon2-cffi-bindings/argon2-cffi-bindings-21.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/argon2-cffi-bindings/argon2-cffi-bindings-21.2.0.ebuild b/dev-python/argon2-cffi-bindings/argon2-cffi-bindings-21.2.0.ebuild
new file mode 100644
index 000000000000..e8534118a0e3
--- /dev/null
+++ b/dev-python/argon2-cffi-bindings/argon2-cffi-bindings-21.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Low-level CFFI bindings for the Argon2 password hashing library"
+HOMEPAGE="https://github.com/hynek/argon2-cffi-bindings"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_sse2"
+
+DEPEND="app-crypt/argon2:="
+BDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+src_configure() {
+ export ARGON2_CFFI_USE_SYSTEM=1
+ # We cannot call usex in global scope, so we invoke it in src_configure
+ export ARGON2_CFFI_USE_SSE2=$(usex cpu_flags_x86_sse2 1 0)
+ distutils-r1_src_configure
+}