summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-19 23:40:26 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-19 23:41:20 +0100
commit71f3be6fe1cb74c4d40cf4980e74a23a91ed0757 (patch)
treefd29f4d6d1bcc9311623f0dac8ce4545eeb93772 /dev-python/argon2-cffi
parentdev-python/pyproject2setuppy: Bump to v22 (diff)
downloadgentoo-71f3be6fe1cb74c4d40cf4980e74a23a91ed0757.tar.gz
gentoo-71f3be6fe1cb74c4d40cf4980e74a23a91ed0757.tar.bz2
gentoo-71f3be6fe1cb74c4d40cf4980e74a23a91ed0757.zip
dev-python/argon2-cffi: Support pp2sp-22
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argon2-cffi')
-rw-r--r--dev-python/argon2-cffi/argon2-cffi-21.2.0.ebuild1
-rw-r--r--dev-python/argon2-cffi/argon2-cffi-21.3.0-r1.ebuild40
-rw-r--r--dev-python/argon2-cffi/argon2-cffi-21.3.0.ebuild1
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/argon2-cffi/argon2-cffi-21.2.0.ebuild b/dev-python/argon2-cffi/argon2-cffi-21.2.0.ebuild
index 959e84069e39..4b92a9605e4c 100644
--- a/dev-python/argon2-cffi/argon2-cffi-21.2.0.ebuild
+++ b/dev-python/argon2-cffi/argon2-cffi-21.2.0.ebuild
@@ -17,6 +17,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
RDEPEND=">=dev-python/argon2-cffi-bindings-21.2.0[${PYTHON_USEDEP}]"
BDEPEND="
+ <dev-python/pyproject2setuppy-22[${PYTHON_USEDEP}]
test? (
dev-python/hypothesis[${PYTHON_USEDEP}]
)
diff --git a/dev-python/argon2-cffi/argon2-cffi-21.3.0-r1.ebuild b/dev-python/argon2-cffi/argon2-cffi-21.3.0-r1.ebuild
new file mode 100644
index 000000000000..8317e93d5c4a
--- /dev/null
+++ b/dev-python/argon2-cffi/argon2-cffi-21.3.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="CFFI bindings to the Argon2 password hashing library"
+HOMEPAGE="https://github.com/hynek/argon2-cffi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND=">=dev-python/argon2-cffi-bindings-21.2.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ >=dev-python/pyproject2setuppy-22[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( AUTHORS.rst FAQ.rst README.rst )
+
+src_prepare() {
+ # Sphinx's conf.py uses importlib.metadata to determine the package
+ # version. However, argon2-cffi is not installed when we try to build
+ # the docs. Therefore, we patch the release version in conf.py.
+ sed -i -e "/^release/s:= .*:= \"${PV}\":" \
+ "docs/conf.py" || die "Unable to patch version in docs"
+ distutils-r1_src_prepare
+}
+
+distutils_enable_sphinx docs \
+ dev-python/furo \
+ dev-python/sphinx-notfound-page
+distutils_enable_tests pytest
diff --git a/dev-python/argon2-cffi/argon2-cffi-21.3.0.ebuild b/dev-python/argon2-cffi/argon2-cffi-21.3.0.ebuild
index 3a28d9718394..00502332253a 100644
--- a/dev-python/argon2-cffi/argon2-cffi-21.3.0.ebuild
+++ b/dev-python/argon2-cffi/argon2-cffi-21.3.0.ebuild
@@ -17,6 +17,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
RDEPEND=">=dev-python/argon2-cffi-bindings-21.2.0[${PYTHON_USEDEP}]"
BDEPEND="
+ <dev-python/pyproject2setuppy-22[${PYTHON_USEDEP}]
test? (
dev-python/hypothesis[${PYTHON_USEDEP}]
)