summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-24 07:57:50 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-24 09:01:52 +0200
commita85d07ce86ce75c61ae6d2690819e813bfd7ca21 (patch)
treeff3f184137ea4b7403722458f1c2553e52170f67 /dev-python/asgiref
parentdev-python/pydantic: Bump to 1.10.8 (diff)
downloadgentoo-a85d07ce86ce75c61ae6d2690819e813bfd7ca21.tar.gz
gentoo-a85d07ce86ce75c61ae6d2690819e813bfd7ca21.tar.bz2
gentoo-a85d07ce86ce75c61ae6d2690819e813bfd7ca21.zip
dev-python/asgiref: Bump to 3.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asgiref')
-rw-r--r--dev-python/asgiref/Manifest1
-rw-r--r--dev-python/asgiref/asgiref-3.7.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/asgiref/Manifest b/dev-python/asgiref/Manifest
index 7d49a31d16c0..83a75d400228 100644
--- a/dev-python/asgiref/Manifest
+++ b/dev-python/asgiref/Manifest
@@ -1 +1,2 @@
DIST asgiref-3.6.0.tar.gz 32748 BLAKE2B ce3facb2d026551df31ab28a3d9c4bb22be6828664d3b341369eb5dffaec1f2a519ab84356ec89dcfe112a96430be66c70c53d7e36586a3b2f4ee1db61a9d617 SHA512 b74d71e3a5d129117293512ed93e06a9ac0f681766abfc074be6c8deec7160995dee23947da861715fa47e2b9921669b6b5bf247f8d895ffbea7007ea956b9d6
+DIST asgiref-3.7.0.tar.gz 33247 BLAKE2B 512d497d57e45b2ea8d0db1d7bd12ebd850087291698067b050988137e4795eb784796ac8ec6cfcce3a67d9cbf11fb88d4a441e5dfd4e9d177400efe979837e9 SHA512 f4672a1ec652e4f05114caf19e1036a6bc71b137af48214292d5f5348340563a450e13520424aae74d75a58c9dbae7acf4f2debf54acbf5c24310e6bf911ac3f
diff --git a/dev-python/asgiref/asgiref-3.7.0.ebuild b/dev-python/asgiref/asgiref-3.7.0.ebuild
new file mode 100644
index 000000000000..f82d77df50c5
--- /dev/null
+++ b/dev-python/asgiref/asgiref-3.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="ASGI utilities (successor to WSGI)"
+HOMEPAGE="
+ https://asgi.readthedocs.io/en/latest/
+ https://github.com/django/asgiref/
+ https://pypi.org/project/asgiref/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest