summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-06 15:58:00 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-06 16:14:34 +0200
commit0327feeaa2e6f499ff186228d3bee56ca4124fcd (patch)
tree0ec2bf9ede6394fe6eeb8d738286890d6074869d /dev-python/astroid
parentdev-python/pybtex-docutils: Enable py3.13 (diff)
downloadgentoo-0327feeaa2e6f499ff186228d3bee56ca4124fcd.tar.gz
gentoo-0327feeaa2e6f499ff186228d3bee56ca4124fcd.tar.bz2
gentoo-0327feeaa2e6f499ff186228d3bee56ca4124fcd.zip
dev-python/astroid: Deselect tests failing with numpy-2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/astroid-3.2.2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/astroid/astroid-3.2.2.ebuild b/dev-python/astroid/astroid-3.2.2.ebuild
index 84488dfc368a..791c68302437 100644
--- a/dev-python/astroid/astroid-3.2.2.ebuild
+++ b/dev-python/astroid/astroid-3.2.2.ebuild
@@ -33,7 +33,6 @@ BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
dev-python/attrs[${PYTHON_USEDEP}]
- <dev-python/numpy-2[${PYTHON_USEDEP}]
>=dev-python/numpy-1.17.0[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
@@ -59,6 +58,14 @@ python_test() {
tests/test_nodes.py::AsStringTest::test_recursion_error_trapped
# TODO
tests/test_builder.py::BuilderTest::test_data_build_error_filename
+ # numpy-2
+ tests/brain/numpy/test_core_einsumfunc.py::test_numpy_function_calls_inferred_as_ndarray
+ tests/brain/numpy/test_core_fromnumeric.py::BrainNumpyCoreFromNumericTest::test_numpy_function_calls_inferred_as_ndarray
+ tests/brain/numpy/test_core_multiarray.py::BrainNumpyCoreMultiarrayTest::test_numpy_function_calls_inferred_as_ndarray
+ tests/brain/numpy/test_core_numerictypes.py::NumpyBrainCoreNumericTypesTest::test_datetime_astype_return
+ tests/brain/numpy/test_core_numerictypes.py::NumpyBrainCoreNumericTypesTest::test_generic_types_are_subscriptables
+ tests/brain/numpy/test_core_umath.py::NumpyBrainCoreUmathTest::test_numpy_core_umath_functions_return_type
+ tests/brain/numpy/test_core_umath.py::NumpyBrainCoreUmathTest::test_numpy_core_umath_functions_return_type_tuple
)
case ${EPYTHON} in