summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-29 12:06:26 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-29 12:06:26 +0100
commit22b013c04c3c4a8236d82d099518ebff0972a53b (patch)
tree381e01e9e82464c1b3adbbe8ca921ef2a3a59182 /dev-python/autopep8
parentdev-python/aioresponses: Remove old (diff)
downloadgentoo-22b013c04c3c4a8236d82d099518ebff0972a53b.tar.gz
gentoo-22b013c04c3c4a8236d82d099518ebff0972a53b.tar.bz2
gentoo-22b013c04c3c4a8236d82d099518ebff0972a53b.zip
dev-python/autopep8: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest1
-rw-r--r--dev-python/autopep8/autopep8-2.0.4.ebuild47
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index e787dafcbf50..41712f9ee349 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,2 +1 @@
-DIST autopep8-2.0.4.tar.gz 116472 BLAKE2B c6e6d207e9e27db450b74fe63fc3c8dce1e6729e0c86046e3efb2a7e749ff402e4cb33062a10c49db7a5f158b12df35088686425a9d822a32b8a4fb6185aae7c SHA512 2c3731d328d0128b4e93c9cb05d730cdf4e08cb18b73ca0de3ac24462feb3e1e61c805ce4cef67f0df2db04773657d0efae70cbca9a67fa5d2790b07daeafeac
DIST autopep8-2.0.4_p20231027.gh.tar.gz 146180 BLAKE2B 3818423c9683157df0c3ed905a225228da7ca44a361247aecbc84b70bd5476a148c6ceb38598b84ff337bf66b1fadcbec47c79738954d90fe1f04f31a467441a SHA512 28c88acd0863d7f6a7333150ce9b916e4776eefacc7eeb7c4de14a3c823c9331fb15fef03f2288ae921ddef37c19191a6550b152df6331d075217908ab1b3a7f
diff --git a/dev-python/autopep8/autopep8-2.0.4.ebuild b/dev-python/autopep8/autopep8-2.0.4.ebuild
deleted file mode 100644
index a55c69972647..000000000000
--- a/dev-python/autopep8/autopep8-2.0.4.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="
- https://github.com/hhatto/autopep8/
- https://pypi.org/project/autopep8/
-"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
- inherit git-r3
-else
- inherit pypi
- KEYWORDS="~alpha amd64 arm64 ~ia64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/pycodestyle-2.10[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.{8..10})
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=()
-
- [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
- # fails due to deprecation warnings
- test/test_autopep8.py::CommandLineTests::test_in_place_no_modifications_no_writes
- test/test_autopep8.py::CommandLineTests::test_in_place_no_modifications_no_writes_with_empty_file
- )
-
- epytest
-}