summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-05 11:06:24 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-05 11:06:24 +0200
commite2517ec4d10ba5ca5fde354dcedc227516c3e01e (patch)
treed1ed418913074e4c29db7c1c148e81d9affb1011 /dev-python/aws-xray-sdk
parentnet-libs/nghttp3: Keyword 1.3.0 riscv, #933292 (diff)
downloadgentoo-e2517ec4d10ba5ca5fde354dcedc227516c3e01e.tar.gz
gentoo-e2517ec4d10ba5ca5fde354dcedc227516c3e01e.tar.bz2
gentoo-e2517ec4d10ba5ca5fde354dcedc227516c3e01e.zip
dev-python/aws-xray-sdk: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aws-xray-sdk')
-rw-r--r--dev-python/aws-xray-sdk/Manifest1
-rw-r--r--dev-python/aws-xray-sdk/aws-xray-sdk-2.13.0.ebuild90
2 files changed, 0 insertions, 91 deletions
diff --git a/dev-python/aws-xray-sdk/Manifest b/dev-python/aws-xray-sdk/Manifest
index 17dface3ca34..e32dacc3ee48 100644
--- a/dev-python/aws-xray-sdk/Manifest
+++ b/dev-python/aws-xray-sdk/Manifest
@@ -1,3 +1,2 @@
-DIST aws-xray-sdk-python-2.13.0.gh.tar.gz 276162 BLAKE2B 60a8cf121139b5a704f47676a10534a7e9e5cbbcadc3a10e2f864f2d6baef8b0d8fe82ef9356d3e459d21628584ec98d4a89ad31b8d982dc8859d0cdb0240999 SHA512 c36907788a891a8adef94591172c53dcc0ebde5c0a3552154a313d93af66d50d88aa3422c1abeba89e629aa224beee5eb17e14f272ee312c76aa7f437fadb77c
DIST aws-xray-sdk-python-2.13.1.gh.tar.gz 276762 BLAKE2B 3be776b549ff9d0684670b30bbcd3323bf41ea6b8cc6ca2c2de0c3e7b168386ff9776472d53874c30c34fa1e21e890366270639df8319133ca250aa26deb8802 SHA512 6410fe3664ab82fcf6b1770f6e5ec9416d5cf28e9a11940a9dab0816a699696e91befdc642d7c3fdfde37cf6d19a0213e833be831d8cb0ac9645c3e16919d780
DIST aws-xray-sdk-python-2.14.0.gh.tar.gz 276813 BLAKE2B ce9a6c8a3b9acd4cb1e538c75702bebc1e392d350a999e8c609ddb900acadd0ecef11b2ce326786a64a73de3d84b0e18e6f4dd4ad91ece6a13283d727039925c SHA512 e9f7a299e35741a63de999dbd4931b82aab97b4c690e9abec4d25106a4a1b1dbbda605b7ec8541000f97cdcf17fed1283abf8d561db63cc4ac1ed11405458f29
diff --git a/dev-python/aws-xray-sdk/aws-xray-sdk-2.13.0.ebuild b/dev-python/aws-xray-sdk/aws-xray-sdk-2.13.0.ebuild
deleted file mode 100644
index 323ba5a787a4..000000000000
--- a/dev-python/aws-xray-sdk/aws-xray-sdk-2.13.0.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=aws-xray-sdk-python-${PV}
-DESCRIPTION="AWS X-Ray SDK for Python"
-HOMEPAGE="
- https://github.com/aws/aws-xray-sdk-python/
- https://pypi.org/project/aws-xray-sdk/
-"
-SRC_URI="
- https://github.com/aws/aws-xray-sdk-python/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/botocore-1.12.122[${PYTHON_USEDEP}]
- dev-python/wrapt[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/bottle[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/webtest[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x DJANGO_SETTINGS_MODULE=tests.ext.django.app.settings
- local -x AWS_SECRET_ACCESS_KEY=fake_key
- local -x AWS_ACCESS_KEY_ID=fake_id
-
- local EPYTEST_DESELECT=(
- # Internet access
- tests/test_patcher.py::test_external_file
- tests/test_patcher.py::test_external_module
- tests/test_patcher.py::test_external_submodules_full
- tests/test_patcher.py::test_external_submodules_ignores_file
- tests/test_patcher.py::test_external_submodules_ignores_module
- # benchmark
- tests/test_local_sampling_benchmark.py
- # Fails, probably because above is ignored
- tests/test_async_local_storage.py::test_localstorage_isolation
- tests/test_async_recorder.py::test_capture
- tests/test_async_recorder.py::test_concurrent_calls
- tests/test_async_recorder.py::test_async_context_managers
- # connects to local mysqld
- tests/ext/sqlalchemy_core/test_dburl.py::test_db_url_with_special_char
- # TODO
- tests/test_lambda_context.py::test_disable
- tests/test_lambda_context.py::test_facade_segment_generation
- tests/test_lambda_context.py::test_put_subsegment
- )
- local EPYTEST_IGNORE=(
- # unpackaged deps
- tests/ext/aiobotocore
- tests/ext/pg8000
- tests/ext/psycopg2
- tests/ext/pymysql
- tests/ext/pynamodb
- tests/ext/sqlalchemy_core/test_postgres.py
- tests/ext/django/test_db.py
- # Internet access
- tests/ext/httplib
- tests/ext/httpx
- tests/ext/requests
- # requires old package vesions
- tests/ext/aiohttp
- tests/ext/django
- tests/ext/flask_sqlalchemy
- tests/ext/sqlalchemy
- )
-
- epytest -p no:django
-}