summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-18 11:31:24 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-18 13:16:51 +0100
commita936489d4b4a34ee09185c678b66d0292d956bd6 (patch)
tree68c9cde0c325d1cc3732632f7956c6bbd105e473 /dev-python/axiom/axiom-0.7.5.ebuild
parentkde-apps/ffmpegthumbs: do not block SLOT 4 (diff)
downloadgentoo-a936489d4b4a34ee09185c678b66d0292d956bd6.tar.gz
gentoo-a936489d4b4a34ee09185c678b66d0292d956bd6.tar.bz2
gentoo-a936489d4b4a34ee09185c678b66d0292d956bd6.zip
dev-python/axiom: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/axiom/axiom-0.7.5.ebuild')
-rw-r--r--dev-python/axiom/axiom-0.7.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/axiom/axiom-0.7.5.ebuild b/dev-python/axiom/axiom-0.7.5.ebuild
new file mode 100644
index 000000000000..10cca0b2c6d1
--- /dev/null
+++ b/dev-python/axiom/axiom-0.7.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit twisted-r1
+
+DESCRIPTION="Object database implemented on top of SQLite"
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodAxiom https://pypi.python.org/pypi/Axiom"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/epsilon-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-13.2.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.5.30-sqlite3_3.6.4.patch" )
+
+TWISTED_PLUGINS+=( axiom.plugins )
+
+python_install() {
+ distutils-r1_python_install
+
+ touch "${D}$(python_get_sitedir)"/axiom/plugins/dropin.cache || die
+}