summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-18 15:13:43 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-18 17:45:38 +0200
commitb7bcb34f8bebe157a99316b72472f7c172d45d04 (patch)
tree38ac86e834d8d45f6ff3a5284b4ea670f3bc6a56 /dev-python/blinker
parentdev-python/pikepdf: Require dev-python/pillow[lcms] (diff)
downloadgentoo-b7bcb34f8bebe157a99316b72472f7c172d45d04.tar.gz
gentoo-b7bcb34f8bebe157a99316b72472f7c172d45d04.tar.bz2
gentoo-b7bcb34f8bebe157a99316b72472f7c172d45d04.zip
dev-python/blinker: Add missing pytest-asyncio dep
Closes: https://bugs.gentoo.org/930185 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/blinker')
-rw-r--r--dev-python/blinker/blinker-1.7.0.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-python/blinker/blinker-1.7.0.ebuild b/dev-python/blinker/blinker-1.7.0.ebuild
index caa91f2b57eb..c965ec466d37 100644
--- a/dev-python/blinker/blinker-1.7.0.ebuild
+++ b/dev-python/blinker/blinker-1.7.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,4 +18,15 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio
+}