summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-06-06 23:54:17 +0200
committerPacho Ramos <pacho@gentoo.org>2020-06-07 00:22:00 +0200
commit4b80346db49b4dd4d46f5f8d32ab99a1b9ad072c (patch)
tree5ed0ec6dd8aff9e639d21cae392e2854fac6de16 /dev-python/blosc
parentdev-python/scikit-build: Bump to 0.11.1 supporting py3.8 (diff)
downloadgentoo-4b80346db49b4dd4d46f5f8d32ab99a1b9ad072c.tar.gz
gentoo-4b80346db49b4dd4d46f5f8d32ab99a1b9ad072c.tar.bz2
gentoo-4b80346db49b4dd4d46f5f8d32ab99a1b9ad072c.zip
dev-python/blosc: Bump to 1.9.1 supporting py3.8
Closes: https://bugs.gentoo.org/650408 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python/blosc')
-rw-r--r--dev-python/blosc/Manifest1
-rw-r--r--dev-python/blosc/blosc-1.9.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/blosc/Manifest b/dev-python/blosc/Manifest
index e370ac442769..7ba02f1914c6 100644
--- a/dev-python/blosc/Manifest
+++ b/dev-python/blosc/Manifest
@@ -1 +1,2 @@
DIST blosc-1.5.1.tar.gz 641172 BLAKE2B 2305c8a4b32192393182306c1ae074caff1bab28b7c842c14f737354c282aa30ae1f9d6cfa5c4932832c505a9d1eb1a579cd2303d1800ae42e52fc58100ca99a SHA512 76d8c5d9e0e3485aacd5646970ce62e34d6ef3ff04e134342544ab044c4d1925a537187b4ce8b7ef3f6cd327e26d47dbdf1bf04233186a8baedbc7c839071cf8
+DIST blosc-1.9.1.tar.gz 809621 BLAKE2B fdeb76e5714d94a9992b59b99926a54457850c69d9d2c217b5a57cd8ce0d8886853ec139683a68c96d3a697b11f68163a7f267cd6060eacba78f595d4ff67d5d SHA512 61ed4e184c1a3e19a2556e5eb4f30030c00294af7b2d5b6c0641160db53c65756170c138229edd684f41606b2a3ae0b1c4f5e01495e74875e5123d7e1d8ed9c2
diff --git a/dev-python/blosc/blosc-1.9.1.ebuild b/dev-python/blosc/blosc-1.9.1.ebuild
new file mode 100644
index 000000000000..50df9cddf599
--- /dev/null
+++ b/dev-python/blosc/blosc-1.9.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="High performance compressor optimized for binary data"
+HOMEPAGE="http://python-blosc.blosc.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/c-blosc:="
+DEPEND="${RDEPEND}
+ dev-python/scikit-build[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ export BLOSC_DIR="${EPREFIX}/usr"
+ distutils-r1_python_prepare_all
+ DOCS=( ANNOUNCE.rst README.rst RELEASE_NOTES.rst )
+}
+
+python_compile_all() {
+ esetup.py build_clib
+ esetup.py build_ext --inplace
+ esetup.py build
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ PYTHONPATH=. nosetests -v || die
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}