summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-10 21:29:58 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-10 22:30:34 +0200
commita3ea150ce6740584732d29fa396bc08ba1c1fb86 (patch)
tree5b3892b023f8d2df8723a4505167f7980b6f1ec4 /dev-python/boto/boto-2.49.0-r2.ebuild
parentdev-python/pip: keyworded 20.0.2 for hppa (diff)
downloadgentoo-a3ea150ce6740584732d29fa396bc08ba1c1fb86.tar.gz
gentoo-a3ea150ce6740584732d29fa396bc08ba1c1fb86.tar.bz2
gentoo-a3ea150ce6740584732d29fa396bc08ba1c1fb86.zip
dev-python/boto: Port to py3.9, fix tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto/boto-2.49.0-r2.ebuild')
-rw-r--r--dev-python/boto/boto-2.49.0-r2.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/dev-python/boto/boto-2.49.0-r2.ebuild b/dev-python/boto/boto-2.49.0-r2.ebuild
index ae8ee2a25f36..0e774e24a221 100644
--- a/dev-python/boto/boto-2.49.0-r2.ebuild
+++ b/dev-python/boto/boto-2.49.0-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1
@@ -13,22 +13,26 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="test"
-
-BDEPEND="
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-RESTRICT="!test? ( test )"
-
-# requires Amazon Web Services keys to pass some tests
-RESTRICT+=" test"
PATCHES=(
# taken from https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=909545
"${FILESDIR}/boto-try-to-add-SNI-support-v2.patch"
+ "${FILESDIR}"/${P}-py38.patch
)
+distutils_enable_tests nose
+
+src_prepare() {
+ # broken, not worth fixing
+ rm tests/unit/cloudfront/test_signed_urls.py || die
+ # fix tests
+ mkdir -p "${HOME}"/.ssh || die
+ : > "${HOME}"/.ssh/known_hosts || die
+
+ distutils-r1_src_prepare
+}
+
python_test() {
- "${PYTHON}" tests/test.py -v || die "Tests fail with ${EPYTHON}"
+ nosetests -v tests/unit ||
+ die "Tests fail with ${EPYTHON}"
}