summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-22 08:12:21 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-22 09:06:57 +0100
commit50b174047e6c503e19c3df1b088f8fb4dc827682 (patch)
treed86b1b72725de223e75db606e507541a1b57989f /dev-python/botocore
parentnet-misc/youtube-dl: Bump to 2020.12.22 (diff)
downloadgentoo-50b174047e6c503e19c3df1b088f8fb4dc827682.tar.gz
gentoo-50b174047e6c503e19c3df1b088f8fb4dc827682.tar.bz2
gentoo-50b174047e6c503e19c3df1b088f8fb4dc827682.zip
dev-python/botocore: Bump to 1.19.41
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.41.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index f12aca30ea69..5907eb04af7b 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,3 +2,4 @@ DIST botocore-1.19.23.tar.gz 7090433 BLAKE2B c5b6801e169b7c0325b33b005be0e409644
DIST botocore-1.19.30.tar.gz 7224700 BLAKE2B 50712be7e6e4a8a22607d567a8d227bbc6d9a7156c245a9faa5adf0e94364d5e5738dd558534e072d071e88315fd79555454fd5f36dfb5d309effca6a39f2247 SHA512 8d9a0becad072ac01e04c1709e8851344bbcd35ecb6c269cace7c229e3b2e48b8fd91ca31be96c67831030a75a63027e8700772601a65eb529bcfd8a58434b6c
DIST botocore-1.19.36.tar.gz 7291325 BLAKE2B d1f79298a0f47d704418cac8390a5d500b1f300fc9bdbc0b215a3630adb70c29a951c6dff2a6ebfde42872cbc3af4c442d09fa0233b2c957521e6a5e05816c60 SHA512 420ad7c59496b2b74ba6ecde8dc40ac3e47c5676335f7471448fcdde5b70bda3bd7516963788d8a7a940aaa9cf488b6529e6fbd2842806f58520cd8e2dc15a60
DIST botocore-1.19.40.tar.gz 7371480 BLAKE2B afd861d013b78487ff2a6d47a531536f3928c6e21dc88dc1a203d90e335c688a530bc9b253f325a641f4b31fc592dcec39d880e1962118b22a170229c54dbd29 SHA512 9d59a80864926a6ffcee7bd35ae1bc70cb5c373eba97318737f8485d8dc45a3efb4719dd6de64ced58077462eae445862708c04f2e936da6bf1fd7a0c24b3401
+DIST botocore-1.19.41.tar.gz 7368333 BLAKE2B d70ebbcfe4e4d44893f69214bda2341f047ef036434d37bdf3ec632745ac20c30f7321a03ecbfb8e8cdf42052e27a40e8f6c02ab57e471ca7d78ef28640d1029 SHA512 63edfaa02f8b79caca70611cb3ed16732813c072473ab39a4f7525cab882e2b1fac1b4a3664524db76d6288cdb4b6f650492432acaa38e2dd63b46baa7d6d0a2
diff --git a/dev-python/botocore/botocore-1.19.41.ebuild b/dev-python/botocore/botocore-1.19.41.ebuild
new file mode 100644
index 000000000000..ca40b64d111f
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.41.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}