summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-19 07:43:38 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-19 07:43:38 +0200
commit849a01191b136eab0f99a180ce4d8fce1730115b (patch)
treecada60789a64f2cde5274c131b5a306a872a9909 /dev-python/botocore
parentmedia-plugins/kodi-peripheral-joystick: Cleanup old versions (diff)
downloadgentoo-849a01191b136eab0f99a180ce4d8fce1730115b.tar.gz
gentoo-849a01191b136eab0f99a180ce4d8fce1730115b.tar.bz2
gentoo-849a01191b136eab0f99a180ce4d8fce1730115b.zip
dev-python/botocore: Bump to 1.20.75
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.75.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 891065a4369e..9ede253af272 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -10,3 +10,4 @@ DIST botocore-1.20.71.tar.gz 7720081 BLAKE2B 4f5d4f237222a034d2102cb637722c7d63a
DIST botocore-1.20.72.tar.gz 7719833 BLAKE2B 23bdce05a95ebcc162e26e91923999ba50910f2fd1d78830c64ee4cb685b2f58e0f14b71c22d34973e2588590fa8af35868f696bbe7719f710baad49d7d1753d SHA512 d46cf353c1df60e24e8e3def8ccf4821bbc36366d25c073330133e4d6ebf83491c5d82dd708c14df65ebbcc08c7705fd3d1d37339742719bdaf58678e04d7824
DIST botocore-1.20.73.tar.gz 7725102 BLAKE2B ccb41513630d8016718cba5e7cc172efb985688f8537dd7f434707f05f9222f486a42c3c84cf25edb437836f04d5ae024292a15a2e784c600bbdebf7dc34d9e3 SHA512 7b1fadcc4e337f0c7498b46cbc0779f20ceb864e2b3974c15a947f18925691ecaaf455bfd7de153d26632a2035a1f922c64320887d06203285947b4310f07e10
DIST botocore-1.20.74.tar.gz 7729804 BLAKE2B 0693da2be219ee140c5c00a540756d31651d3e4c78976a7f766705123e9fba23e98d73e551b86a6b661530c20abb560b0e36fea8e1c13600303894b3163d2274 SHA512 51bcf78c6804b4a8cddd57eeff96d7ecb65731dfbd87eb665de1356c1daedb4317323b3a0d905e3d459800d800ce6d6ffd8fd1239b26ecf56884bee37159f2b7
+DIST botocore-1.20.75.tar.gz 7750681 BLAKE2B 4cf5700ccdd43a7d963fc60c7e0db5204947e6d3c63747882fa01856ab4e97bba5f4174a8f4252e3389d6aa6436473f9124f445a53b2cc4233b8d7ed22cb5fef SHA512 736f9d8e4875fd273e73e25ba791117c146c0facdd68970f8d2127245805383119178faa4c91d9dc43ec045e59bf39dbece40d6946013ce9c8ac3c5d1ef9bd84
diff --git a/dev-python/botocore/botocore-1.20.75.ebuild b/dev-python/botocore/botocore-1.20.75.ebuild
new file mode 100644
index 000000000000..afca295f8bed
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.75.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}