summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-20 05:11:12 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-20 05:49:54 +0100
commitea11897abb1729821ae8f4f23c0216fa12fbfa80 (patch)
tree304505bac502cd90867431cc5fdbff007f6cc62d /dev-python/bottleneck
parentdev-python/trove-classifiers: Bump to 2023.1.20 (diff)
downloadgentoo-ea11897abb1729821ae8f4f23c0216fa12fbfa80.tar.gz
gentoo-ea11897abb1729821ae8f4f23c0216fa12fbfa80.tar.bz2
gentoo-ea11897abb1729821ae8f4f23c0216fa12fbfa80.zip
dev-python/bottleneck: Bump to 1.3.6
Closes: https://bugs.gentoo.org/887851 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bottleneck')
-rw-r--r--dev-python/bottleneck/Manifest1
-rw-r--r--dev-python/bottleneck/bottleneck-1.3.6.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/bottleneck/Manifest b/dev-python/bottleneck/Manifest
index 354f8498053b..315fda104cfa 100644
--- a/dev-python/bottleneck/Manifest
+++ b/dev-python/bottleneck/Manifest
@@ -1 +1,2 @@
DIST bottleneck-1.3.5.gh.tar.gz 118989 BLAKE2B 5b9338a77cb3f0253348f45e641dca9fce11b50fb632e697272203870dd604730c08f1adc94ebf9c6c21f551e3f06b5492bcb036d6f40eaec8853d08ca298873 SHA512 9a0f224337fd9d5c741a1e469197be26923eaffb143eddfe0969128ddc233c799da6a5f2ba4ef22f6267cf93e7f748c140fbb16f57149ad327c47fe87ffc3346
+DIST bottleneck-1.3.6.gh.tar.gz 119180 BLAKE2B 8ba4ccb260731b1583eb62249fa0bdf8d25b96c978f5ff91003aaf965b0f5f5d000fb2a049f70e86266ebeb6e748cadd8e7d0ccafad1ed1a50f6aba18452c97a SHA512 0c0af2ee5ca77f86f855800748a4ce4c0fe85f9da445aeeaaffabdcdc0e2c47b18c5590b208cb8aed52d4ec4a1aa9c023588d11d1c5aa581e2c00d3d4c1ba73c
diff --git a/dev-python/bottleneck/bottleneck-1.3.6.ebuild b/dev-python/bottleneck/bottleneck-1.3.6.ebuild
new file mode 100644
index 000000000000..e256737dfd03
--- /dev/null
+++ b/dev-python/bottleneck/bottleneck-1.3.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast NumPy array functions written in C"
+HOMEPAGE="
+ https://github.com/pydata/bottleneck/
+ https://pypi.org/project/Bottleneck/
+"
+SRC_URI="
+ https://github.com/pydata/bottleneck/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.9.1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # don't overwrites user's optimization level
+ sed -e '/extra_compile_args=\["-O2"\]/d' -i setup.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ epytest
+}