summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-30 09:26:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-03-30 09:49:41 +0200
commita58a5b94bd9bd6dca9f777c2cc09bf85e9fb166a (patch)
tree09593010c55d5856ce315e2d05d9b4c01180ec43 /dev-python/breathe/breathe-4.28.0.ebuild
parentRevert "sys-apps/sg3_utils: Removed old" (diff)
downloadgentoo-a58a5b94bd9bd6dca9f777c2cc09bf85e9fb166a.tar.gz
gentoo-a58a5b94bd9bd6dca9f777c2cc09bf85e9fb166a.tar.bz2
gentoo-a58a5b94bd9bd6dca9f777c2cc09bf85e9fb166a.zip
dev-python/breathe: Bump to 4.28.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/breathe/breathe-4.28.0.ebuild')
-rw-r--r--dev-python/breathe/breathe-4.28.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/breathe/breathe-4.28.0.ebuild b/dev-python/breathe/breathe-4.28.0.ebuild
new file mode 100644
index 000000000000..335bb076fa0b
--- /dev/null
+++ b/dev-python/breathe/breathe-4.28.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx Doxygen renderer"
+HOMEPAGE="https://breathe.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/michaeljones/breathe/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-doc/doxygen
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-3.0.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+"
+
+distutils_enable_tests pytest