summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-16 10:35:19 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-16 10:35:19 +0100
commitf2190426e69efe559f706cf770646b16c75aa5cd (patch)
treead6442e8cd39a0b5a913fcb4f65bcb9b4ce24920 /dev-python/build
parentdev-python/build: Stabilize 1.1.1 ALLARCHES, #927129 (diff)
downloadgentoo-f2190426e69efe559f706cf770646b16c75aa5cd.tar.gz
gentoo-f2190426e69efe559f706cf770646b16c75aa5cd.tar.bz2
gentoo-f2190426e69efe559f706cf770646b16c75aa5cd.zip
dev-python/build: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/build')
-rw-r--r--dev-python/build/Manifest1
-rw-r--r--dev-python/build/build-1.0.3.ebuild64
2 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/build/Manifest b/dev-python/build/Manifest
index 9ff1951a3941..f4af5f0b5577 100644
--- a/dev-python/build/Manifest
+++ b/dev-python/build/Manifest
@@ -1,2 +1 @@
-DIST build-1.0.3.gh.tar.gz 43412 BLAKE2B cb707b21582a1f7a5f649dcaf0fa7d30d253641a51c6af1284b17df46ad877af5280b5d1a07ce7eb90ef468d0f850e3e85dba1f24f7942c6ba432789760ae670 SHA512 c2c67ccf407bb1780c90e02bbc2692b8b10cfe441f445c05d38a675f3498d1d6f94306dcbe270c181e14471f1dd3712e2cba33a4792f6140e2e9f0aa3c8e7b81
DIST build-1.1.1.gh.tar.gz 44605 BLAKE2B aa1d554d55007e8cb715981938bb8765230ae5ddc6c5bc29efeb52c0e18b6337a13c27f3389772a83cc0ecc9b7d3e889fbc305e91f1290424d7031a1782f683f SHA512 5fa64b07f2c22faca074d1447f5fcb12b7ad40e5fe897f034901d7932d8a9aa2c1dfa806d373503246255d7d9a2429b336384a980376f4ae7c810ae275b735da
diff --git a/dev-python/build/build-1.0.3.ebuild b/dev-python/build/build-1.0.3.ebuild
deleted file mode 100644
index b5380c983e46..000000000000
--- a/dev-python/build/build-1.0.3.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="A simple, correct PEP517 package builder"
-HOMEPAGE="
- https://pypi.org/project/build/
- https://github.com/pypa/build/
-"
-SRC_URI="
- https://github.com/pypa/build/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/packaging-19.0[${PYTHON_USEDEP}]
- dev-python/pyproject-hooks[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- >=dev-python/filelock-3[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-2[${PYTHON_USEDEP}]
- >=dev-python/pytest-rerunfailures-9.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-1.34[${PYTHON_USEDEP}]
- >=dev-python/setuptools-56.0.0[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.36.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/pypa/build/pull/722
- "${FILESDIR}/${P}-setuptools-69.patch"
-)
-
-python_test() {
- local EPYTEST_DESELECT=(
- # broken by the presence of flit_core
- tests/test_util.py::test_wheel_metadata_isolation
- # broken by the presence of virtualenv (it changes the error
- # messages, sic!)
- 'tests/test_main.py::test_output[via-sdist-isolation]'
- 'tests/test_main.py::test_output[wheel-direct-isolation]'
- # broken when built in not normal tty on coloring
- tests/test_main.py::test_colors
- 'tests/test_main.py::test_output_env_subprocess_error[color]'
- )
-
- epytest -m "not network" -p no:flaky \
- -n "$(makeopts_jobs)" --dist=worksteal
-}