summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-03 22:23:21 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-03 23:21:39 +0100
commit9ab45e8874826b8c7d83eb4939bcee0e5b8318ce (patch)
tree7074bbde6618e3333ca0aa04612ea2c12a17f345 /dev-python/clang-python
parentsys-devel/clang: Update slot for master to 7 (diff)
downloadgentoo-9ab45e8874826b8c7d83eb4939bcee0e5b8318ce.tar.gz
gentoo-9ab45e8874826b8c7d83eb4939bcee0e5b8318ce.tar.bz2
gentoo-9ab45e8874826b8c7d83eb4939bcee0e5b8318ce.zip
dev-python/clang-python: Add a live ebuild for 6.0 branch
Diffstat (limited to 'dev-python/clang-python')
-rw-r--r--dev-python/clang-python/clang-python-6.0.9999.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-6.0.9999.ebuild b/dev-python/clang-python/clang-python-6.0.9999.ebuild
new file mode 100644
index 000000000000..e0aa3318ebd9
--- /dev/null
+++ b/dev-python/clang-python/clang-python-6.0.9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit git-r3 python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/clang.git
+ https://github.com/llvm-mirror/clang.git"
+EGIT_BRANCH="release_60"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}/bindings/python
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' bindings/python
+}
+
+src_test() {
+ python_foreach_impl python -m unittest discover -v || die
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}