summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-27 18:27:52 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-27 18:27:52 +0200
commitbffeec800d813a86a7ae59ef2f6a42dedd04b004 (patch)
treed6bc243acfc891310d883ef0173680396ba0f7ea /dev-python/cli-helpers
parentdev-python/cli_helpers: Prepare for rename (diff)
downloadgentoo-bffeec800d813a86a7ae59ef2f6a42dedd04b004.tar.gz
gentoo-bffeec800d813a86a7ae59ef2f6a42dedd04b004.tar.bz2
gentoo-bffeec800d813a86a7ae59ef2f6a42dedd04b004.zip
Rename dev-python/{cli_helpers → cli-helpers}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cli-helpers')
-rw-r--r--dev-python/cli-helpers/Manifest1
-rw-r--r--dev-python/cli-helpers/cli-helpers-2.3.0.ebuild35
-rw-r--r--dev-python/cli-helpers/cli-helpers-9999.ebuild30
-rw-r--r--dev-python/cli-helpers/metadata.xml11
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/cli-helpers/Manifest b/dev-python/cli-helpers/Manifest
new file mode 100644
index 000000000000..4499213caf40
--- /dev/null
+++ b/dev-python/cli-helpers/Manifest
@@ -0,0 +1 @@
+DIST cli_helpers-2.3.0.gh.tar.gz 34374 BLAKE2B 83978ee17aec8a02173460cf5d5c42751d4745c63a1f83c8fafdd55fcfb31e04d02a61f90db4a4fe8ba2049167306b06e1389db15230558a646589e3834745de SHA512 ee5f2adbca54c62c2f40be4c7b418760d12f331737a65bafdb8209989fc866f35d6c2ea1b9b0a12add6ed3fa576a84a2c8f62a2f3babf58706660f7d7eb8eb57
diff --git a/dev-python/cli-helpers/cli-helpers-2.3.0.ebuild b/dev-python/cli-helpers/cli-helpers-2.3.0.ebuild
new file mode 100644
index 000000000000..9138c1963998
--- /dev/null
+++ b/dev-python/cli-helpers/cli-helpers-2.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=cli_helpers-${PV}
+DESCRIPTION="Python helpers for common CLI tasks"
+HOMEPAGE="
+ https://cli-helpers.rtfd.io/
+ https://github.com/dbcli/cli_helpers/
+ https://pypi.org/project/cli-helpers/
+"
+SRC_URI="
+ https://github.com/dbcli/cli_helpers/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+
+RDEPEND="
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/cli-helpers/cli-helpers-9999.ebuild b/dev-python/cli-helpers/cli-helpers-9999.ebuild
new file mode 100644
index 000000000000..fa2b087f7224
--- /dev/null
+++ b/dev-python/cli-helpers/cli-helpers-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python helpers for common CLI tasks"
+HOMEPAGE="
+ https://cli-helpers.rtfd.io/
+ https://github.com/dbcli/cli_helpers/
+ https://pypi.org/project/cli-helpers/
+"
+EGIT_REPO_URI="https://github.com/dbcli/cli_helpers.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/cli-helpers/metadata.xml b/dev-python/cli-helpers/metadata.xml
new file mode 100644
index 000000000000..79ba6aa529dd
--- /dev/null
+++ b/dev-python/cli-helpers/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">dbcli/cli_helpers</remote-id>
+ <remote-id type="pypi">cli-helpers</remote-id>
+ </upstream>
+</pkgmetadata>