summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-10 14:22:39 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-10 17:24:49 +0100
commit603792fcc68b490648bc8eda6ca2932e9b797459 (patch)
tree9869f77064ca709719c10bb134fe952114203daa /dev-python/clr-loader
parentdev-dotnet/fsautocomplete: drop old 0.68.0 (diff)
downloadgentoo-603792fcc68b490648bc8eda6ca2932e9b797459.tar.gz
gentoo-603792fcc68b490648bc8eda6ca2932e9b797459.tar.bz2
gentoo-603792fcc68b490648bc8eda6ca2932e9b797459.zip
dev-python/clr-loader: use dotnet-pkg_force-compat and nuget_writeconfig
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-python/clr-loader')
-rw-r--r--dev-python/clr-loader/clr-loader-0.2.6.ebuild21
1 files changed, 6 insertions, 15 deletions
diff --git a/dev-python/clr-loader/clr-loader-0.2.6.ebuild b/dev-python/clr-loader/clr-loader-0.2.6.ebuild
index 79b410339ac2..b3a9bcf26c64 100644
--- a/dev-python/clr-loader/clr-loader-0.2.6.ebuild
+++ b/dev-python/clr-loader/clr-loader-0.2.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -51,19 +51,20 @@ DOTNET_PKG_PROJECTS=(
)
EPYTEST_DESELECT=(
- # Mono
+ # Mono only.
'tests/test_common.py::test_mono'
'tests/test_common.py::test_mono_debug'
'tests/test_common.py::test_mono_signal_chaining'
'tests/test_common.py::test_mono_set_dir'
- # MS Windows only
+ # MS Windows only.
'tests/test_common.py::test_netfx'
'tests/test_common.py::test_netfx_chinese_path'
'tests/test_common.py::test_netfx_separate_domain'
)
distutils_enable_tests pytest
+dotnet-pkg_force-compat
pkg_setup() {
check-reqs_pkg_setup
@@ -71,8 +72,6 @@ pkg_setup() {
}
src_prepare() {
- distutils-r1_src_prepare
-
# To be compatible with .NET >= 6.0.
cat <<-EOF > Directory.Build.props || die
<Project>
@@ -81,17 +80,9 @@ src_prepare() {
</PropertyGroup>
</Project>
EOF
+ nuget_writeconfig "$(pwd)/"
- # Because python scripts perform the build.
- cat <<EOF > NuGet.config || die
-<?xml version="1.0" encoding="utf-8"?>
-<configuration>
-<packageSources>
-<clear />
-<add key="nuget" value="${NUGET_PACKAGES}" />
-</packageSources>
-</configuration>
-EOF
+ distutils-r1_src_prepare
}
src_configure() {