summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-31 21:02:02 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-31 21:08:46 +0200
commita2c904044f2cde8a056dcdc3b2b93c37ad6b6d58 (patch)
treeecf81588ea32cabcd2ed64beeec6e2ff72228408 /dev-python/configclass
parentdev-python/mergedict: Enable py3.12 (diff)
downloadgentoo-a2c904044f2cde8a056dcdc3b2b93c37ad6b6d58.tar.gz
gentoo-a2c904044f2cde8a056dcdc3b2b93c37ad6b6d58.tar.bz2
gentoo-a2c904044f2cde8a056dcdc3b2b93c37ad6b6d58.zip
dev-python/configclass: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/configclass')
-rw-r--r--dev-python/configclass/configclass-0.2.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/configclass/configclass-0.2.0-r1.ebuild b/dev-python/configclass/configclass-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..4448881b41c7
--- /dev/null
+++ b/dev-python/configclass/configclass-0.2.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python to class to hold configuration values"
+HOMEPAGE="
+ https://github.com/schettino72/configclass/
+ https://pypi.org/project/configclass/
+"
+SRC_URI="
+ https://github.com/schettino72/configclass/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/mergedict-0.2.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest