summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-12-29 17:36:14 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-12-29 19:56:00 +0000
commitea4e17b3a5831451644db3105ebc2c9bb5aa5371 (patch)
tree14822957613558c2dde14e639fa2df4f2a1a333f /dev-python/corner
parentapp-portage/gentoolkit: Version bump (diff)
downloadgentoo-ea4e17b3a5831451644db3105ebc2c9bb5aa5371.tar.gz
gentoo-ea4e17b3a5831451644db3105ebc2c9bb5aa5371.tar.bz2
gentoo-ea4e17b3a5831451644db3105ebc2c9bb5aa5371.zip
dev-python/corner: initial import
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/corner')
-rw-r--r--dev-python/corner/Manifest1
-rw-r--r--dev-python/corner/corner-2.0.1.ebuild25
-rw-r--r--dev-python/corner/metadata.xml21
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/corner/Manifest b/dev-python/corner/Manifest
new file mode 100644
index 000000000000..ac67e8d478cf
--- /dev/null
+++ b/dev-python/corner/Manifest
@@ -0,0 +1 @@
+DIST corner-2.0.1.tar.gz 10534 SHA256 102e22797ee75d1432b6dc66aa2850f61388996ece66fd6600508742d2a7b88f SHA512 ebd625ab1e4591b4c21d25ec706c35d37f560b727e1e0d6a79948c4a112ee6f21d3ca30162901a27715074e1345f3bdee1a0345c63e5fec24113e495fb094127 WHIRLPOOL c485239f8b810ff46b29eee9e204537c256a3d9786ef6f885854bb82e0554403ca7a68d37c2a4f1f46bf4064cea09ad4f87d15838563435183c4946e10fc3110
diff --git a/dev-python/corner/corner-2.0.1.ebuild b/dev-python/corner/corner-2.0.1.ebuild
new file mode 100644
index 000000000000..45467d889f1d
--- /dev/null
+++ b/dev-python/corner/corner-2.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Make scatter matrix corner plots"
+HOMEPAGE="http://corner.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# missing expected test images in tar ball (2.0.1)
+RESTRICT=test
diff --git a/dev-python/corner/metadata.xml b/dev-python/corner/metadata.xml
new file mode 100644
index 000000000000..b8f3109ff572
--- /dev/null
+++ b/dev-python/corner/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ This Python module uses matplotlib to visualize multidimensional
+ samples using a scatterplot matrix. In these visualizations, each
+ one- and two-dimensional projection of the sample is plotted to
+ reveal covariances. corner was originally conceived to display the
+ results of Markov Chain Monte Carlo simulations and the defaults
+ are chosen with this application in mind but it can be used for
+ displaying many qualitatively different samples.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">corner</remote-id>
+ <remote-id type="github">dfm/corner.py</remote-id>
+ </upstream>
+</pkgmetadata>