summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-11 19:27:23 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-11 19:27:23 +0200
commit15e097d757366d9e414158ad65834d7d30d6c290 (patch)
tree6e640885483fe4baa6cfa79ab22fc0daa0c90af0 /dev-python/dbus-python
parentdev-python/aws-sam-translator: Bump to 1.53.0 (diff)
downloadgentoo-15e097d757366d9e414158ad65834d7d30d6c290.tar.gz
gentoo-15e097d757366d9e414158ad65834d7d30d6c290.tar.bz2
gentoo-15e097d757366d9e414158ad65834d7d30d6c290.zip
dev-python/dbus-python: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/Manifest1
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.18.ebuild85
2 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/dbus-python/Manifest b/dev-python/dbus-python/Manifest
index 5a867914faec..a7ad92adada0 100644
--- a/dev-python/dbus-python/Manifest
+++ b/dev-python/dbus-python/Manifest
@@ -1,2 +1 @@
-DIST dbus-python-1.2.18.tar.gz 578204 BLAKE2B 932a06f4b0145f7a47cf1ab6ea33c14eb4e36570ef548e7557d4aa5b780e49f2d284cdb51f0ec2d8a1cb286097fb9eabb2193d7cbeb387eaf43cbe209b7f11fa SHA512 72f422c59637392bd78b741b66dff2afadcc706452c3e82fdc14b1dc052a0c5cb8a85e2758d18c5cbdc08004419a0b3c16b67b99688d96307084403e72585900
DIST dbus-python-1.3.2.tar.gz 605495 BLAKE2B 6c60217b3837d655ab4f833b9f21d8f76eb4129cfeaa26586ef7adc8be8f8c5f03464428ff9f281b2566fb0f89cbb5e4b5618bf7cc961faf9f638d9011874839 SHA512 9b2885c9c2914142c72487f766b1cdd28a255d9f5a87eaf8f4eb420c6e096a77f210ac5a4fac9843c6531974872880cc28b7e45940e198856e984dcc0715519a
diff --git a/dev-python/dbus-python/dbus-python-1.2.18.ebuild b/dev-python/dbus-python/dbus-python-1.2.18.ebuild
deleted file mode 100644
index 30ce5fa1aed5..000000000000
--- a/dev-python/dbus-python/dbus-python-1.2.18.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..11} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit autotools python-r1
-
-DESCRIPTION="Python bindings for the D-Bus messagebus"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/DBusBindings/ https://dbus.freedesktop.org/doc/dbus-python/"
-SRC_URI="https://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-IUSE="doc examples test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="${PYTHON_DEPS}
- >=sys-apps/dbus-1.8:=
- >=dev-libs/glib-2.40
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- doc? ( $(python_gen_any_dep '
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- ') )
- test? ( dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/tappy[${PYTHON_USEDEP}] )
-"
-
-python_check_deps() {
- python_has_version "dev-python/sphinx[${PYTHON_USEDEP}]" \
- "dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]"
-}
-
-src_prepare() {
- default
- # Update py-compile, bug 529502.
- eautoreconf
- python_copy_sources
-}
-
-src_configure() {
- use doc && python_setup
- local SPHINX_IMPL=${EPYTHON}
-
- configuring() {
- local myconf=(
- --disable-documentation
-
- # Work around broken AX_PYTHON_DEVEL macro.
- # https://bugs.gentoo.org/815136
- PYTHON_EXTRA_LIBS=' '
- )
- [[ ${EPYTHON} == ${SPHINX_IMPL} ]] &&
- myconf+=( --enable-documentation )
-
- econf "${myconf[@]}"
- }
- python_foreach_impl run_in_build_dir configuring
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- python_foreach_impl run_in_build_dir default
- find "${D}" -name '*.la' -type f -delete || die
-
- use examples && dodoc -r examples
-}