summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-03-11 21:01:34 +0100
committerPacho Ramos <pacho@gentoo.org>2020-03-11 22:28:51 +0100
commitce3eb3e9fd9b4b2173eec4c4d8130029888a5e2b (patch)
tree7e394a812599ea07aa97e4c4850132a80233f2c8 /dev-python/defcon
parentdev-python/git-python: Bump to 3.1.0, py3.8, tests (diff)
downloadgentoo-ce3eb3e9fd9b4b2173eec4c4d8130029888a5e2b.tar.gz
gentoo-ce3eb3e9fd9b4b2173eec4c4d8130029888a5e2b.tar.bz2
gentoo-ce3eb3e9fd9b4b2173eec4c4d8130029888a5e2b.zip
dev-python/defcon: Drop python2 support
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python/defcon')
-rw-r--r--dev-python/defcon/defcon-0.6.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/defcon/defcon-0.6.0-r1.ebuild b/dev-python/defcon/defcon-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..61979f96a84d
--- /dev/null
+++ b/dev-python/defcon/defcon-0.6.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="A set of UFO based objects for use in font editing applications"
+HOMEPAGE="https://github.com/typesupply/defcon"
+SRC_URI="https://github.com/typesupply/defcon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-python/fonttools-3.31.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+python_test() {
+ esetup.py test
+}