summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-16 17:49:39 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-16 18:30:03 +0100
commit5cddffb83d16ea4f95600180e44b762e26fe011e (patch)
tree54c6a7cc817c7adfbd8903ce44b72a1275b2d6c3 /dev-python/dict2xml
parentdev-python/hypothesis: Bump to 6.94.0 (diff)
downloadgentoo-5cddffb83d16ea4f95600180e44b762e26fe011e.tar.gz
gentoo-5cddffb83d16ea4f95600180e44b762e26fe011e.tar.bz2
gentoo-5cddffb83d16ea4f95600180e44b762e26fe011e.zip
dev-python/dict2xml: Bump to 1.7.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dict2xml')
-rw-r--r--dev-python/dict2xml/Manifest1
-rw-r--r--dev-python/dict2xml/dict2xml-1.7.4.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/dict2xml/Manifest b/dev-python/dict2xml/Manifest
index d21c4a53a176..fdc3fc52ebf3 100644
--- a/dev-python/dict2xml/Manifest
+++ b/dev-python/dict2xml/Manifest
@@ -1 +1,2 @@
DIST dict2xml-1.7.3.tar.gz 14240 BLAKE2B b28343f2cfeb59a91011bb158ffe7db008f19be1576293e6b07c3b49e07f3871761c8a3a32c214bf0608602487e2e7110c7f2a2f31a7dbf44a441f44ca7f568b SHA512 631415e425688c612c15b72fc339db33977df32eb25f7f8f03a63e5115c8e06f4aa5b247ded3e16cddbb9b16597aeb0ef218f193c5f4c44ebdcd7e39c2052ed2
+DIST dict2xml-1.7.4.tar.gz 14333 BLAKE2B 9d1a5180d6cffed171aa973902d6e88190b8bd90cd9e4d86744b5c074d82e45c7571763aa9cca67d190cf7af1b1fdd155cbff906a44a638dcb3a7033f1be86ba SHA512 13a2b34783e5f6414c173059ba16a2061ecaef41355b7b0099546d704c9c28b1e0f9ea3186d4b0db99083e66a2f22e69e57a4a415b72c00fd1e17bcb435e7462
diff --git a/dev-python/dict2xml/dict2xml-1.7.4.ebuild b/dev-python/dict2xml/dict2xml-1.7.4.ebuild
new file mode 100644
index 000000000000..b23f9330ef96
--- /dev/null
+++ b/dev-python/dict2xml/dict2xml-1.7.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Small utility to convert a python dictionary into an XML string"
+HOMEPAGE="
+ https://github.com/delfick/python-dict2xml/
+ https://pypi.org/project/dict2xml/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# dict2xml uses noseOfYeti for its test, which is not yet available.
+RESTRICT="test"
+
+distutils_enable_tests pytest