summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-07-26 23:14:26 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-02 21:14:41 +0300
commit3447f783465da762b956c9261199dbc8d1eca193 (patch)
tree31405e1c884d73578c1eadb66e1a0ee6db0cd328 /dev-python/dissononce/dissononce-0.34.3.ebuild
parentdev-python/consonance: New package (diff)
downloadgentoo-3447f783465da762b956c9261199dbc8d1eca193.tar.gz
gentoo-3447f783465da762b956c9261199dbc8d1eca193.tar.bz2
gentoo-3447f783465da762b956c9261199dbc8d1eca193.zip
dev-python/dissononce: New package
This is a new dependency for the >=net-im/yowsup-3 version bump. Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/dissononce/dissononce-0.34.3.ebuild')
-rw-r--r--dev-python/dissononce/dissononce-0.34.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/dissononce/dissononce-0.34.3.ebuild b/dev-python/dissononce/dissononce-0.34.3.ebuild
new file mode 100644
index 000000000000..c5583d3590b2
--- /dev/null
+++ b/dev-python/dissononce/dissononce-0.34.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python implementation for Noise Protocol Framework"
+HOMEPAGE="https://github.com/tgalal/dissononce"
+SRC_URI="https://github.com/tgalal/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+# Currently no tests are available,
+# they will be added in future by upstream.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/transitions[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${P}-fix-test-requirements.patch" )
+
+python_test() {
+ esetup.py test
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ use examples && dodoc examples/patterns/*.py
+}