summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-17 18:19:31 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-17 19:03:05 +0200
commit04c267269a65d57a7455f15658122e9fd9e96b5e (patch)
tree5a718a015c5d4b0656d22542375b809e19ac00fe /dev-python/django-auth-ldap
parentdev-python/cfn-lint: Bump to 1.17.0 (diff)
downloadgentoo-04c267269a65d57a7455f15658122e9fd9e96b5e.tar.gz
gentoo-04c267269a65d57a7455f15658122e9fd9e96b5e.tar.bz2
gentoo-04c267269a65d57a7455f15658122e9fd9e96b5e.zip
dev-python/django-auth-ldap: Bump to 5.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-auth-ldap')
-rw-r--r--dev-python/django-auth-ldap/Manifest1
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-5.1.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/Manifest b/dev-python/django-auth-ldap/Manifest
index 7132f438618a..974a994cdcbe 100644
--- a/dev-python/django-auth-ldap/Manifest
+++ b/dev-python/django-auth-ldap/Manifest
@@ -1,2 +1,3 @@
DIST django-auth-ldap-4.8.0.tar.gz 53906 BLAKE2B 76542bfb59c998a681f5e4a4ec0fcae406a672e2fea6b20ef6f59a91987626bec0186d853b789ce0006ace8d0fdbb3b8b2e5855eb84d6d6c93c7040056e4a397 SHA512 4ca16bd5d11680127d2cecfeb7d1d48175e1b9b02e13f84d6845b76a4f52be3ef6c72d5b4bef4418b4f48b441830d3b593fef6cc08a8cd4221c78cfd8464ac8a
DIST django_auth_ldap-5.0.0.tar.gz 54873 BLAKE2B b310d96bcb034644acd97626bda214074547033685785b6a90b0785fe93297b79b5d0b3199259220a0f40186996d6c990a4163d8c0bf8e9af1a52b7eedf5f26c SHA512 043ad6b6b9d36456975833433bf088f8d41d203a8eeec2e5db5edf4ac2d4cc62aaccd52ee45ca8ca47882986f47048467e88a88c6fac51a515e44a3d560c7e44
+DIST django_auth_ldap-5.1.0.tar.gz 55059 BLAKE2B 4c1cf5cf7113b90be392b519c0ecfceeb72568a6e50803bd276becca22fffb3ec7222069b374e311156d2e4c559b65985af2a740e0a78ec66b398622db66da47 SHA512 3b1257c91d1651df83c1c0343b8f0658d1e9e6b23cbb161ec2f5c847d9c924609509b28f3d1efde9c09e890b73191f0a6a6e9bd802cb4c6985c0c36b5955a9dd
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-5.1.0.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-5.1.0.ebuild
new file mode 100644
index 000000000000..7da953673b01
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-5.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="
+ https://github.com/django-auth-ldap/django-auth-ldap/
+ https://pypi.org/project/django-auth-ldap/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-3.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ net-nds/openldap[-minimal]
+ )
+"
+
+distutils_enable_sphinx docs --no-autodoc
+
+python_test() {
+ # for slapd and slapdtest
+ local -x SBIN=/usr/sbin:/usr/$(get_libdir)/openldap
+ "${EPYTHON}" -m django test -v 2 --settings tests.settings ||
+ die "Tests failed with ${EPYTHON}"
+}