summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/django-discover-runner
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/django-discover-runner')
-rw-r--r--dev-python/django-discover-runner/Manifest2
-rw-r--r--dev-python/django-discover-runner/django-discover-runner-0.4.ebuild21
-rw-r--r--dev-python/django-discover-runner/django-discover-runner-1.0.ebuild22
-rw-r--r--dev-python/django-discover-runner/metadata.xml9
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/django-discover-runner/Manifest b/dev-python/django-discover-runner/Manifest
new file mode 100644
index 000000000000..514083ae078a
--- /dev/null
+++ b/dev-python/django-discover-runner/Manifest
@@ -0,0 +1,2 @@
+DIST django-discover-runner-0.4.tar.gz 6764 SHA256 c802a9f19ee9cf55f478c3b664ee6f5ea8973b58248d24aa8c9e2dc65b9fa885 SHA512 594b06915f373b77da3cdbe3e91e989fa6b4befea55381dff63e457f6c5dba9d9b7e4ebd77b88f97b51176e002915bdc8d11bc8e95908cdb4089da2cf997897b WHIRLPOOL 77e127c1b90fb7d1115734a2852d0edfbce56ee3a60e55dbd2a948402819ba694bac1ba4631460b796080a7b4e1e1f84cc41b99dcc2986e1acce5ad2f9a61db4
+DIST django-discover-runner-1.0.tar.gz 9190 SHA256 0ba91fe722c256bcbfdeb36fac7eac0f27e5bfda55d98c4c1cf9ab62b5b084fe SHA512 669287ed7f801dbfe949e2affd9ee1861aa6a41fcc2e2403dc2e106dee3d23c8400d686ef750242bdc74d23eaf316fcf36071c82d7c458ff724305e5fe27410e WHIRLPOOL 67f0e6cf59f4aab1db1012f27e12cc0ea1e3101ed1c066cd1294ec2455f17ee5e4ce5afb3b381a4bd03cb4cd97863c284199ed77ba3c89d430668ab80d723528
diff --git a/dev-python/django-discover-runner/django-discover-runner-0.4.ebuild b/dev-python/django-discover-runner/django-discover-runner-0.4.ebuild
new file mode 100644
index 000000000000..5967def84925
--- /dev/null
+++ b/dev-python/django-discover-runner/django-discover-runner-0.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django test runner based on unittest2's test discovery"
+HOMEPAGE="https://github.com/jezdez/django-discover-runner
+ https://pypi.python.org/pypi/django-discover-runner"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/django[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/django-discover-runner/django-discover-runner-1.0.ebuild b/dev-python/django-discover-runner/django-discover-runner-1.0.ebuild
new file mode 100644
index 000000000000..f80f174dcd48
--- /dev/null
+++ b/dev-python/django-discover-runner/django-discover-runner-1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django test runner based on unittest2's test discovery"
+HOMEPAGE="https://github.com/jezdez/django-discover-runner
+ https://pypi.python.org/pypi/django-discover-runner"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/django-discover-runner/metadata.xml b/dev-python/django-discover-runner/metadata.xml
new file mode 100644
index 000000000000..7c1cce3d2a32
--- /dev/null
+++ b/dev-python/django-discover-runner/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">django-discover-runner</remote-id>
+ <remote-id type="github">jezdez/django-discover-runner</remote-id>
+ </upstream>
+</pkgmetadata>