summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-12 04:24:25 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-12 04:50:29 +0200
commit80888d4a00a4aaf92576bca253e62b637f981189 (patch)
treef9c346b72fa1b734e1e3d0151959aa65324d5c09 /dev-python/django-sortedm2m
parentdev-python/tifffile: Bump to 2024.8.10 (diff)
downloadgentoo-80888d4a00a4aaf92576bca253e62b637f981189.tar.gz
gentoo-80888d4a00a4aaf92576bca253e62b637f981189.tar.bz2
gentoo-80888d4a00a4aaf92576bca253e62b637f981189.zip
dev-python/django-sortedm2m: Bump to 4.0.0
Closes: https://bugs.gentoo.org/923002 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-sortedm2m')
-rw-r--r--dev-python/django-sortedm2m/Manifest1
-rw-r--r--dev-python/django-sortedm2m/django-sortedm2m-4.0.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/django-sortedm2m/Manifest b/dev-python/django-sortedm2m/Manifest
index e111b753e407..d6d7fcd9c2f6 100644
--- a/dev-python/django-sortedm2m/Manifest
+++ b/dev-python/django-sortedm2m/Manifest
@@ -1 +1,2 @@
DIST django-sortedm2m-3.1.1.gh.tar.gz 45888 BLAKE2B 878a23d5f5dad114b0b6ef9bd687d4e23620c823a8ad33a66b7c6c1e598db15e5328a46373dd6d7fd9449b4ba533e21664db716cde40150af2451a74f2f28fda SHA512 440c049a1fbe54c0db8edb0a5a737b5d84553afb7305d21a64c2dbac02f143e6f17e7e0499a4d3e687b13f292558d7818c030d78d8cc9443048a95ae6b50204f
+DIST django-sortedm2m-4.0.0.gh.tar.gz 43476 BLAKE2B 07cec1cce786e64642ec2ed620e5db11c6f33efe701f9e2b2a1b5081ce91631d4e3524595729cd390fed4acce48eb07193a25a8d3ac1ff66d7895cccd84b3515 SHA512 90d407ca78d264b3b6262896cdb45de64a9d60f2a7a99e8daa0a62adf104d245e5bd142c9c7020f0cfeb17ebe5f311295f67e4b40ce78095d6b02bc3d480c77f
diff --git a/dev-python/django-sortedm2m/django-sortedm2m-4.0.0.ebuild b/dev-python/django-sortedm2m/django-sortedm2m-4.0.0.ebuild
new file mode 100644
index 000000000000..0f019fc8c8f2
--- /dev/null
+++ b/dev-python/django-sortedm2m/django-sortedm2m-4.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Drop-in replacement for django's many to many field with sorted relations"
+HOMEPAGE="
+ https://pypi.org/project/django-sortedm2m/
+ https://github.com/jazzband/django-sortedm2m/
+"
+SRC_URI="
+ https://github.com/jazzband/django-sortedm2m/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ local -x PYTHONPATH=test_project:${PYTHONPATH}
+ local -x DB_ENGINE=sqlite3
+ local -x DB_NAME=":memory:"
+ django-admin test -v 2 --settings=settings --noinput sortedm2m_tests ||
+ die "Tests fail with ${EPYTHON}"
+}