summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-16 09:12:20 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-16 09:46:09 +0100
commit21727cfbd5a328b5bf049157fc60e7628c87ab4f (patch)
tree946ebad337cd069ee30e75a9464f5ecb18f34268 /dev-python/djangorestframework
parentdev-python/jsonschema: Bump to 4.3.0 (diff)
downloadgentoo-21727cfbd5a328b5bf049157fc60e7628c87ab4f.tar.gz
gentoo-21727cfbd5a328b5bf049157fc60e7628c87ab4f.tar.bz2
gentoo-21727cfbd5a328b5bf049157fc60e7628c87ab4f.zip
dev-python/djangorestframework: Bump to 3.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/djangorestframework')
-rw-r--r--dev-python/djangorestframework/Manifest1
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.13.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
index c5191d400bca..66fbe9674dbb 100644
--- a/dev-python/djangorestframework/Manifest
+++ b/dev-python/djangorestframework/Manifest
@@ -1,2 +1,3 @@
DIST django-rest-framework-3.12.4.gh.tar.gz 8856507 BLAKE2B 48150e8d966ddd169a2b58d90656efa8f9f549c9d2fdee6025254fba2a6221704fe6bcb246567c8acb963f76ea56046935d3190c7c391daf4773b100a641ba02 SHA512 406b5354809b94e371a2c7d4b62ce66c18a1f60bd02574cba603ad4c44faa4297bdbbd6ee50de63fe21d2aae18386e05d46983a506bddd17f06ce610d5b727c9
DIST django-rest-framework-3.13.0.gh.tar.gz 8880253 BLAKE2B 8acd6bf386ef20302c8fe52b3a5f1926c03701b32b8c409d13771d632a62e0e01bd8c2efde079e923342a08e6a3d21b3ab13a66817567fe2372f7b8e63eee61a SHA512 2368f382e6dd01490366443ad944f4a48ebbc4928ed45ff58c77a63deb251b148b9e4b13d89b0d2e27a8e257239d75f58f91a11604402683c1c36fac8ce27acc
+DIST django-rest-framework-3.13.1.gh.tar.gz 8868916 BLAKE2B 01a2e1c2459f99b1d3b38b62b305a57f3a3358d34a352ef2bbeb6b130c98f19fbbb83325d1013c28107f267a0a0227215646975de54542ab9ca6dfcf2bd88404 SHA512 a272cccf1f19b2cd09ef456a9588fb17ddc56ac3bd735cf7e130d85bb667ca87361d7de26c95b58a05d8cf693ab19c09d913b457f17ad63053ff9b516c13ec9b
diff --git a/dev-python/djangorestframework/djangorestframework-3.13.1.ebuild b/dev-python/djangorestframework/djangorestframework-3.13.1.ebuild
new file mode 100644
index 000000000000..db2bbeb43bbe
--- /dev/null
+++ b/dev-python/djangorestframework/djangorestframework-3.13.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=django-rest-framework-${PV}
+DESCRIPTION="Web APIs with django made easy"
+HOMEPAGE="https://www.django-rest-framework.org/"
+SRC_URI="
+ https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/coreapi[${PYTHON_USEDEP}]
+ dev-python/coreschema[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest