summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-19 18:59:28 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-19 19:17:58 +0200
commit3855b65f41fc3606b10bb262c2fbe6e57cdf1402 (patch)
treef1196ff8714b71b5ed1fcaada909dc01b7225753 /dev-python/dnspython/dnspython-2.0.0.ebuild
parentdev-python/boto3: Bump to 1.14.23 (diff)
downloadgentoo-3855b65f41fc3606b10bb262c2fbe6e57cdf1402.tar.gz
gentoo-3855b65f41fc3606b10bb262c2fbe6e57cdf1402.tar.bz2
gentoo-3855b65f41fc3606b10bb262c2fbe6e57cdf1402.zip
dev-python/dnspython: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dnspython/dnspython-2.0.0.ebuild')
-rw-r--r--dev-python/dnspython/dnspython-2.0.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/dnspython/dnspython-2.0.0.ebuild b/dev-python/dnspython/dnspython-2.0.0.ebuild
new file mode 100644
index 000000000000..7b20dddd4356
--- /dev/null
+++ b/dev-python/dnspython/dnspython-2.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/ https://pypi.org/project/dnspython/"
+SRC_URI="https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.1[${PYTHON_USEDEP}]
+ !dev-python/dnspython:py2
+ !dev-python/dnspython:py3"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ sed -i -e '/network_avail/s:True:False:' \
+ tests/*.py || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}