summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-17 15:13:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-17 15:14:53 +0200
commitcce136a2caa13ef3aea8ac7f7f0872fd8245d44b (patch)
tree66261f923c36273f773a45fb77c76d8869fd6169 /dev-python/elementpath
parentdev-db/mariadb: explicit disable AWS key management encryption plugin (diff)
downloadgentoo-cce136a2caa13ef3aea8ac7f7f0872fd8245d44b.tar.gz
gentoo-cce136a2caa13ef3aea8ac7f7f0872fd8245d44b.tar.bz2
gentoo-cce136a2caa13ef3aea8ac7f7f0872fd8245d44b.zip
dev-python/elementpath: Bump to 2.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-2.2.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index b51e4086098a..424867da2a10 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1 +1,2 @@
DIST elementpath-2.2.2.gh.tar.gz 232791 BLAKE2B c28dcae59d29fe70422b6075a4a9627037726574c41e43947c00ba47054924c179e646a5dc01f2247b72f8c58d4fcfcaf411dfa1970cd6ae1cd2fb9f1f3753be SHA512 3aebfa15ec036674d716e6fc91745a14b897f757ade1df945270d39153ecfa9486d0465e9126a6c71470b191690158a853c3871d493e83ac08e065ce2aed3af3
+DIST elementpath-2.2.3.gh.tar.gz 234094 BLAKE2B e3e56469250f3fd2135d9173d68cd93af2a6e03830859d03872967d72a6b7a39f4bb9288c341cc47c406ad55d764ad65a16169eb78598eeded48c424245064e8 SHA512 75178c12f42582a391aeb8198a45c732601251655e381cf8961dac2f6467217e5a18effcadcaa7e7206b18f358a70e1e4b170b9e02ba9b25108b1721da50ee4e
diff --git a/dev-python/elementpath/elementpath-2.2.3.ebuild b/dev-python/elementpath/elementpath-2.2.3.ebuild
new file mode 100644
index 000000000000..d8a77de4b139
--- /dev/null
+++ b/dev-python/elementpath/elementpath-2.2.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="https://github.com/sissaschool/elementpath/
+ https://pypi.org/project/elementpath/"
+SRC_URI="
+ https://github.com/sissaschool/elementpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest