summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/epsilon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/epsilon')
-rw-r--r--dev-python/epsilon/Manifest2
-rw-r--r--dev-python/epsilon/epsilon-0.6.0-r2.ebuild47
-rw-r--r--dev-python/epsilon/epsilon-0.7.0.ebuild56
-rw-r--r--dev-python/epsilon/files/epsilon_plugincache_portagesandbox.patch12
-rw-r--r--dev-python/epsilon/metadata.xml12
5 files changed, 129 insertions, 0 deletions
diff --git a/dev-python/epsilon/Manifest b/dev-python/epsilon/Manifest
new file mode 100644
index 000000000000..f78f3c15e9b4
--- /dev/null
+++ b/dev-python/epsilon/Manifest
@@ -0,0 +1,2 @@
+DIST Epsilon-0.6.0.tar.gz 96243 SHA256 2be3a6ef877c4e17ca9dadd6b484fe31bdf16c20b949ec6a8b15677e08c512fa SHA512 0ce7ba2eb86811dc50a0e86b9f3d85be1a4f930f86659c2381a1d80455e1e86362b8719c92ae2ad951a34264e5d0649ec5de96f1179734c7fab6c3abc6fb037b WHIRLPOOL 6aa363b44a42f29ec836cf46b2fdfe3bb57541a9fe282b57ea888f4906b9c438c9eb99d5a0876cb11108b7337a0691c45810a3e44579023f0b660e8752952120
+DIST Epsilon-0.7.0.tar.gz 81218 SHA256 81419d50b17a20efd75440d43e4b07fe3c2a5e6d619f39318dab9031a0680032 SHA512 d1927ca431df3233a94296ca9e1f5dd70d6d61091d23f77df2222c6472d9a5f7b55c5c8dd2a75d0fead41af862c9e3a6a0ea9a31e21447459d5182f0d677d9b2 WHIRLPOOL 8cbab28e5e05b44b521c5f66494de1e2f4bee7713487cfb9d87bfcc108dc05b6534919934fd53cb1b0dc7aee633187351973b78cfdabf0584d6b294104a05a57
diff --git a/dev-python/epsilon/epsilon-0.6.0-r2.ebuild b/dev-python/epsilon/epsilon-0.6.0-r2.ebuild
new file mode 100644
index 000000000000..14d90c1870f1
--- /dev/null
+++ b/dev-python/epsilon/epsilon-0.6.0-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1 eutils
+
+DESCRIPTION="Epsilon is a Python utilities package, most famous for its Time class"
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodEpsilon http://pypi.python.org/pypi/Epsilon"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="dev-python/twisted-core[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/epsilon_plugincache_portagesandbox.patch" )
+
+# epsilon doesn't install any plugins, so override the default
+TWISTED_PLUGINS=()
+
+python_prepare_all() {
+ # Rename to avoid file-collisions
+ mv bin/benchmark bin/epsilon-benchmark
+ sed -i \
+ -e "s#bin/benchmark#bin/epsilon-benchmark#" \
+ setup.py || die "sed failed"
+
+ #These test are removed upstream
+ rm -f epsilon/test/test_sslverify.py epsilon/sslverify.py || die
+ #See bug 357157 comment 5 for Ian Delaney's explanation of this fix
+ sed -e 's:month) 2004 9:month) 2004 14:' \
+ -i epsilon/test/test_extime.py || die
+ # Release tests need DivmodCombinator.
+ rm -f epsilon/test/test_release.py* epsilon/release.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ dodoc NAME.txt NEWS.txt
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/epsilon/epsilon-0.7.0.ebuild b/dev-python/epsilon/epsilon-0.7.0.ebuild
new file mode 100644
index 000000000000..7a530fb2f276
--- /dev/null
+++ b/dev-python/epsilon/epsilon-0.7.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1 eutils
+
+DESCRIPTION="Epsilon is a Python utilities package, most famous for its Time class"
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodEpsilon http://pypi.python.org/pypi/Epsilon"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/twisted-core-13.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ ${DEPEND}"
+
+PATCHES=( "${FILESDIR}/epsilon_plugincache_portagesandbox.patch" )
+
+# epsilon doesn't install any plugins, so override the default
+TWISTED_PLUGINS=()
+
+python_prepare_all() {
+ # Rename to avoid file-collisions
+ mv bin/benchmark bin/epsilon-benchmark
+ sed -i \
+ -e "s#bin/benchmark#bin/epsilon-benchmark#" \
+ setup.py || die "sed failed"
+
+ #These test are removed upstream
+ rm -f epsilon/test/test_sslverify.py epsilon/sslverify.py || die
+ #See bug 357157 comment 5 for Ian Delaney's explanation of this fix
+ sed -e 's:month) 2004 9:month) 2004 14:' \
+ -i epsilon/test/test_extime.py || die
+ # Release tests need DivmodCombinator.
+ rm -f epsilon/test/test_release.py* epsilon/release.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ dodoc NAME.txt NEWS.txt
+
+ distutils-r1_python_install_all
+}
+
+#Lets run some tests, having prepped them
+python_test() {
+ # No testrunner seems stipulated within the source; pytest and nosetests both work
+ nosetests ${PN}/test || die "testsuite failed under ${EPYTHON}"
+}
diff --git a/dev-python/epsilon/files/epsilon_plugincache_portagesandbox.patch b/dev-python/epsilon/files/epsilon_plugincache_portagesandbox.patch
new file mode 100644
index 000000000000..06bd55732011
--- /dev/null
+++ b/dev-python/epsilon/files/epsilon_plugincache_portagesandbox.patch
@@ -0,0 +1,12 @@
+--- epsilon/setuphelper.py.orig 2009-02-11 08:15:39.000000000 +0100
++++ epsilon/setuphelper.py 2009-02-11 08:18:56.000000000 +0100
+@@ -21,6 +21,9 @@
+ def _regeneratePluginCache(pluginPackages):
+ print 'Regenerating cache with path: ',
+ pprint.pprint(sys.path)
++ if os.getenv("PORTAGE_PLUGINCACHE_NOOP") != None:
++ print 'Not regenerating plugin cache for portage sandbox usage.'
++ return
+ from twisted import plugin
+ for pluginModule in pluginModules([
+ p + ".plugins" for p in pluginPackages]):
diff --git a/dev-python/epsilon/metadata.xml b/dev-python/epsilon/metadata.xml
new file mode 100644
index 000000000000..326df3b55935
--- /dev/null
+++ b/dev-python/epsilon/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">A small utility package that depends on tools too recent for Twisted
+ (like datetime in python2.4) but performs generic enough functions
+ that it can be used in projects that don't want to share Divmod's
+ other projects' large footprint.</longdescription>
+ <upstream>
+ <remote-id type="pypi">Epsilon</remote-id>
+ </upstream>
+</pkgmetadata>