summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-20 08:18:50 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-20 08:18:50 +0200
commitcd07514347b4af3aec049e26b7243286d620669e (patch)
tree1ad5222123d0ddbfaf9c0814d8c55d313e101435 /dev-python/etuples
parentsys-apps/haveged: remove unused patch (diff)
downloadgentoo-cd07514347b4af3aec049e26b7243286d620669e.tar.gz
gentoo-cd07514347b4af3aec049e26b7243286d620669e.tar.bz2
gentoo-cd07514347b4af3aec049e26b7243286d620669e.zip
dev-python/etuples: add 0.3.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/etuples')
-rw-r--r--dev-python/etuples/Manifest1
-rw-r--r--dev-python/etuples/etuples-0.3.4.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/etuples/Manifest b/dev-python/etuples/Manifest
index 03f2de739e16..c64db8f4f9e2 100644
--- a/dev-python/etuples/Manifest
+++ b/dev-python/etuples/Manifest
@@ -1 +1,2 @@
DIST etuples-0.3.3.gh.tar.gz 42081 BLAKE2B 524ec65a691a7b27f4ccc4d625093a92cd11c9835d3e38498bf89da8690a0bdba5752b3dcdb1e3e9326980920c50f51bc336e7592cbf2561c1ce15346c561cd5 SHA512 cfd2c88f46326783d6b132c605eb3498e383509f45ea8c720148bca7c7fb462e0bf1630da901a362f38cabb0912354a875b99f84beb43b5443333f4bafea5690
+DIST etuples-0.3.4.gh.tar.gz 44650 BLAKE2B 4d0e7235d010ff10e01d4143858bbc2ee1516f66db35fb9c6acf054df898a605a49dc82e4eeaddcb7ab6e5ea9bbd5dec493ac5d1741c4d595756e0f4af0ed1c1 SHA512 4e2c2884cd741a1e85358678347dc65c994583ff700c6a1adaa561bd4446035ccca2e27855fbb5842012f7e2bfa90ef7fa1634e9b3cc43cf9c7006acd7b66595
diff --git a/dev-python/etuples/etuples-0.3.4.ebuild b/dev-python/etuples/etuples-0.3.4.ebuild
new file mode 100644
index 000000000000..ff9f5b15c917
--- /dev/null
+++ b/dev-python/etuples/etuples-0.3.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python S-expression emulation using tuple-like objects"
+HOMEPAGE="
+ https://pypi.org/project/etuples/
+ https://github.com/pythological/etuples/
+"
+SRC_URI="
+ https://github.com/pythological/etuples/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cons[${PYTHON_USEDEP}]
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest