summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-14 16:34:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-14 16:55:17 +0200
commit4b99687c20b8fba80690d060d975c58ff33403e3 (patch)
tree670c57bdb42ce4497acbadabb8ca3a4409ef9113 /dev-python/exceptiongroup
parentdev-python/tenacity: Bump to 8.2.3 (diff)
downloadgentoo-4b99687c20b8fba80690d060d975c58ff33403e3.tar.gz
gentoo-4b99687c20b8fba80690d060d975c58ff33403e3.tar.bz2
gentoo-4b99687c20b8fba80690d060d975c58ff33403e3.zip
dev-python/exceptiongroup: Bump to 1.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/exceptiongroup')
-rw-r--r--dev-python/exceptiongroup/Manifest1
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.1.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/exceptiongroup/Manifest b/dev-python/exceptiongroup/Manifest
index 6ef35014bed4..eb47e285b874 100644
--- a/dev-python/exceptiongroup/Manifest
+++ b/dev-python/exceptiongroup/Manifest
@@ -1 +1,2 @@
DIST exceptiongroup-1.1.2.gh.tar.gz 23079 BLAKE2B f6bce757f1a2672956bf919f3ef0c9c6ea1034bf176e2ed8f3fa92c3fe34974885c59fa9915a42b8d5673b077d48fea3179e12cbd0c39f4277090fdbb3803d08 SHA512 432768f97e3468546b71993fd20ed98d85eb15170228cef8fe39d7c2232d0249c29f6fe1c991313742ee3a22a73cc91336d54ef278337b20e0e2ba296cf7102e
+DIST exceptiongroup-1.1.3.gh.tar.gz 24057 BLAKE2B c178152b92ac4079bb10614918d80f1b772f1d2c02e82fdbc19fc576c434df5f92d731116b46145ef3c3a3e57b4b899f6be11e2452a13170d27072b6b2ad74b5 SHA512 fddc52abb6b61c024c5832f6d2ed723a834c31e2bc713a3c5796581e8edbd3299d9342885cfcb5ed83ad7f7fdbb7c461ffcec354c0328a740a40d5340997d1c8
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.1.3.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.1.3.ebuild
new file mode 100644
index 000000000000..df9172779f44
--- /dev/null
+++ b/dev-python/exceptiongroup/exceptiongroup-1.1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit_scm
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="Backport of PEP 654 (exception groups)"
+HOMEPAGE="
+ https://github.com/agronholm/exceptiongroup/
+ https://pypi.org/project/exceptiongroup/
+"
+# pypi sdist does not include tests as of 1.1.1
+# https://github.com/agronholm/exceptiongroup/pull/59
+SRC_URI="
+ https://github.com/agronholm/exceptiongroup/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT PSF-2.4"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV/_}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}