summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-06 09:09:44 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-06 09:12:58 +0200
commit6fc53050dedf0976973f391a7fdb1de16d0571f8 (patch)
tree00544eb85e8385f326b6c4e58b9619cf2ff014e0 /dev-python/executing
parentdev-python/asttokens: Port to py3.10 (diff)
downloadgentoo-6fc53050dedf0976973f391a7fdb1de16d0571f8.tar.gz
gentoo-6fc53050dedf0976973f391a7fdb1de16d0571f8.tar.bz2
gentoo-6fc53050dedf0976973f391a7fdb1de16d0571f8.zip
dev-python/executing: Bump to 0.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/executing')
-rw-r--r--dev-python/executing/Manifest1
-rw-r--r--dev-python/executing/executing-0.7.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/executing/Manifest b/dev-python/executing/Manifest
index 1439d278479e..54651edfaafe 100644
--- a/dev-python/executing/Manifest
+++ b/dev-python/executing/Manifest
@@ -1 +1,2 @@
DIST executing-0.6.0.gh.tar.gz 330731 BLAKE2B f6a86072907c5140aefb45beb46bcc8c6e3e242e2e821046e59f0eafe1d5c16efe3c08dd1b19b1ce85388fd9cc4757bfe586b95fb490a594cfee4f5e69b5a0af SHA512 5d2f621ff4cbfd55ac43b555f771b129ade5d20f882f4e5d6a060a1a099abad73cc4128c9e6bd32fccc40c4c85c51c28b3be40ab16f163e1ceaaad07f1936ab7
+DIST executing-0.7.0.gh.tar.gz 452550 BLAKE2B 9b3bdb49b3b00ca17952db747d3f0f3995e8dffbc170bcb2260e7c34ce9e6b0c8e1620be2e2776445a6114add4e2437eaeae8a308391e2c121b6484b5bc6056c SHA512 08ee347f0bcaf04ca2c6010762a6d2d5b054b3590029c55d18d6efae5a5db7c6c5a0948cce9d9684e4bfbfd9ea19326e4ac2c96be40535c0500c28c28ce81e07
diff --git a/dev-python/executing/executing-0.7.0.ebuild b/dev-python/executing/executing-0.7.0.ebuild
new file mode 100644
index 000000000000..fc9d9501f8e0
--- /dev/null
+++ b/dev-python/executing/executing-0.7.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Get information about what a Python frame is currently doing"
+HOMEPAGE="
+ https://github.com/alexmojaki/executing/
+ https://pypi.org/project/executing/"
+SRC_URI="
+ https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+# asttokens is optional runtime dep
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ # this test explodes when collected by pytest
+ "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
+ epytest tests/test_pytest.py
+}