summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-16 15:26:15 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-16 16:09:20 +0100
commit653782caa22002ebbe6354ee1b8cbf36e47c97e2 (patch)
tree5a4eefa2b32c552ada751795bd3a48136ab3a768 /dev-python/expandvars
parentdev-python/dep-logic: Bump to 0.0.4 (diff)
downloadgentoo-653782caa22002ebbe6354ee1b8cbf36e47c97e2.tar.gz
gentoo-653782caa22002ebbe6354ee1b8cbf36e47c97e2.tar.bz2
gentoo-653782caa22002ebbe6354ee1b8cbf36e47c97e2.zip
dev-python/expandvars: Bump to 0.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/expandvars')
-rw-r--r--dev-python/expandvars/Manifest1
-rw-r--r--dev-python/expandvars/expandvars-0.12.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/expandvars/Manifest b/dev-python/expandvars/Manifest
index daa32f23ac2c..fe530ced8fc1 100644
--- a/dev-python/expandvars/Manifest
+++ b/dev-python/expandvars/Manifest
@@ -1 +1,2 @@
DIST expandvars-0.11.0.gh.tar.gz 10663 BLAKE2B cfbcb8bedc61cc8b1e88d4774784518e15846f7ea5ddbf58bd016ea2043dd5b1c9e55af117f6482e05e9ae4ba07e01d0fb471a72719f38191f1a29a9f66387a9 SHA512 e8de6544f2d369728e35c8b862662f348f46673f836f8b14dbdcfdc3dbcb7efda80deb55f8bcd597037ac974752e2463d429ddda3b8502fe19c402c253babf7f
+DIST expandvars-0.12.0.tar.gz 10909 BLAKE2B 8d58396f237a0a157f4d57fe9cc79058cdb0b7c514eec405769f67f82b1cf0bd91a98a680e4e730c51d65b0fc57b529f33ef10b96159b6027e4c81cbdeb77fc6 SHA512 b6eeb4693800737aef6367f4fb6080963882c59de2276f187565a764f6b800c747c1d98a1dc2e5107a62ccab420e3528064a1b67ccff8494f8ca2ebf96f05cc6
diff --git a/dev-python/expandvars/expandvars-0.12.0.ebuild b/dev-python/expandvars/expandvars-0.12.0.ebuild
new file mode 100644
index 000000000000..84158d0f7898
--- /dev/null
+++ b/dev-python/expandvars/expandvars-0.12.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Expand system variables Unix style"
+HOMEPAGE="
+ https://github.com/sayanarijit/expandvars/
+ https://pypi.org/project/expandvars/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest