summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-23 21:56:32 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-23 23:17:10 +0200
commit1116865cd30bd6f94b19cafc023877c9b2e6d4bc (patch)
tree0c0bfff4e39a417291000cf63e86e5da8922d4fd /dev-python/fields
parentdev-python/css-parser: Mark ALLARCHES (diff)
downloadgentoo-1116865cd30bd6f94b19cafc023877c9b2e6d4bc.tar.gz
gentoo-1116865cd30bd6f94b19cafc023877c9b2e6d4bc.tar.bz2
gentoo-1116865cd30bd6f94b19cafc023877c9b2e6d4bc.zip
dev-python/fields: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fields')
-rw-r--r--dev-python/fields/fields-5.0.0-r2.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/fields/fields-5.0.0-r2.ebuild b/dev-python/fields/fields-5.0.0-r2.ebuild
index 15946a9d788c..6beb01064bcc 100644
--- a/dev-python/fields/fields-5.0.0-r2.ebuild
+++ b/dev-python/fields/fields-5.0.0-r2.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-DISTUTILS_USE_SETUPTOOLS=bdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Container class boilerplate killer"
@@ -28,9 +26,11 @@ python_prepare_all() {
sed -r \
-e "/--benchmark-disable/d" \
-e 's|\[pytest\]|\[tool:pytest\]|' \
- -e '/^[[:space:]]*--doctest-modules[[:space:]]*$/ d' \
-i setup.cfg || die
- rm -rf tests/test_perf.py || die
distutils-r1_python_prepare_all
}
+
+python_test() {
+ epytest --ignore tests/test_perf.py tests
+}