summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-19 15:47:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-19 15:47:38 +0200
commitd510b329e42a817f55962f171aa11168b7bb5235 (patch)
tree4ef3259e6bd5a3e547a41a43c466a0bbe53a99eb /dev-python/flask-api/flask-api-3.0-r2.ebuild
parentdev-python/flask-login: Fix test compatibility with werkzeug-2.3 (diff)
downloadgentoo-d510b329e42a817f55962f171aa11168b7bb5235.tar.gz
gentoo-d510b329e42a817f55962f171aa11168b7bb5235.tar.bz2
gentoo-d510b329e42a817f55962f171aa11168b7bb5235.zip
dev-python/flask-api: Restrict to <dev-python/flask-2.3
Closes: https://bugs.gentoo.org/906718 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-api/flask-api-3.0-r2.ebuild')
-rw-r--r--dev-python/flask-api/flask-api-3.0-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/flask-api/flask-api-3.0-r2.ebuild b/dev-python/flask-api/flask-api-3.0-r2.ebuild
new file mode 100644
index 000000000000..924851d79164
--- /dev/null
+++ b/dev-python/flask-api/flask-api-3.0-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Browsable web APIs for Flask"
+HOMEPAGE="
+ https://github.com/flask-api/flask-api/
+ https://pypi.org/project/Flask-API/
+"
+# pypi mirror don't have docs folder
+SRC_URI="
+ https://github.com/flask-api/flask-api/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# tests are broken with 2.3, I don't know if the code works
+# https://github.com/flask-api/flask-api/issues/151
+RDEPEND="
+ <dev-python/flask-2.3[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ local DOCS=( docs/about/release-notes.md docs/api-guide/* docs/index.md )
+ distutils-r1_python_install_all
+}