summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-29 10:18:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-29 10:36:17 +0200
commit58fb242aff0c93474c4a41da16e069b6ce20ac78 (patch)
treeaf073af379782ca7df2ab53d3997d02d59c8a5df /dev-python/flask
parentdev-python/decorator: Enable py3.12 (diff)
downloadgentoo-58fb242aff0c93474c4a41da16e069b6ce20ac78.tar.gz
gentoo-58fb242aff0c93474c4a41da16e069b6ce20ac78.tar.bz2
gentoo-58fb242aff0c93474c4a41da16e069b6ce20ac78.zip
dev-python/flask: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/flask-2.3.2.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/flask/flask-2.3.2.ebuild b/dev-python/flask/flask-2.3.2.ebuild
index afba0e94f96e..0e79ed272def 100644
--- a/dev-python/flask/flask-2.3.2.ebuild
+++ b/dev-python/flask/flask-2.3.2.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYPI_PN=${PN^}
-PYTHON_COMPAT=( python3_{10..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1
@@ -41,7 +41,7 @@ RDEPEND="
BDEPEND="
test? (
>=dev-python/asgiref-3.2[${PYTHON_USEDEP}]
- !!dev-python/shiboken2
+ !!dev-python/shiboken2[${PYTHON_USEDEP}]
)
"
@@ -53,6 +53,13 @@ distutils_enable_sphinx docs \
distutils_enable_tests pytest
python_test() {
+ local EPYTEST_DESELECT=()
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ tests/test_basic.py::test_max_cookie_size
+ )
+ fi
+
epytest -p no:httpbin
}